Bug 1315168 - Fd based fops should not be logging ENOENT/ESTALE
Fd based fops should not be logging ENOENT/ESTALE
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks: 1322523
  Show dependency treegraph
 
Reported: 2016-03-07 01:44 EST by Pranith Kumar K
Modified: 2016-06-16 09:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1322523 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:59:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2016-03-07 01:44:55 EST
Description of problem:
Ideally fd based operations shouldn't be logging ENOENT/ESTALE. But it can happen when self-heal is yet to happen where the files need to be re-created etc.
So don't log them as ERRORS

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-03-07 02:10:00 EST
REVIEW: http://review.gluster.org/13621 (protocol/server: Do not log ENOENT in readv) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-03-07 02:19:45 EST
REVIEW: http://review.gluster.org/13621 (protocol/server: Do not log ENOENT/ESTALE in fd based fops) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2016-03-15 11:27:21 EDT
COMMIT: http://review.gluster.org/13621 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit b145cd15ded130078c9f1105e76f35d0886e62d5
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Mar 7 11:52:18 2016 +0530

    protocol/server: Do not log ENOENT/ESTALE in fd based fops
    
    When fd-fops come on anon-fds there is a chance to log ENOENT/ESTALE for them.
    Log it as DEBUG.
    
    Change-Id: I8ae53c29d6a66f6a65081c281a9a5c205f53766b
    BUG: 1315168
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13621
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Niels de Vos 2016-06-16 09:59:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.