Bug 1315194 - Unregister host from webUI doesn't work, firebug raises error
Summary: Unregister host from webUI doesn't work, firebug raises error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1325526 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2016-03-07 08:38 UTC by Sachin Ghai
Modified: 2019-09-26 17:35 UTC (History)
3 users (show)

Fixed In Version: rubygem-hammer_cli_katello-0.0.22.6-1,rubygem-katello-3.0.0.18-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:04:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
unregistering a content-host from webUI doesn't work (105.01 KB, image/png)
2016-03-07 08:38 UTC, Sachin Ghai
no flags Details
webUI raises two option on clicking unregister (88.97 KB, image/png)
2016-04-18 08:27 UTC, Sachin Ghai
no flags Details
host was unregistered successfully from subscription aspect (76.42 KB, image/png)
2016-04-18 08:28 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14196 None None None 2016-04-22 16:17:13 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Sachin Ghai 2016-03-07 08:38:57 UTC
Created attachment 1133681 [details]
unregistering a content-host from webUI doesn't work

Description of problem:
Unregistering a content-host from webUI doesn't work. I was trying to un-register a host from webUI, I select the content-host and clicked on "Unregister Content host" button. A new pop-up appears but that says:

--
Unregister Content Host ""?

Are you sure you want to unregister content host ""?
--

Please note here, the actual name of the host is missing here. Also a javascript error appears in Firebug. Please see the screenshot.

  

Version-Release number of selected component (if applicable):
Satellite 6.2 snap2

How reproducible:
always

Steps to Reproduce:
1. select the content-host from webUI and click on "Unregister Content host" button
2.
3.

Actual results:
A new pop-up appears but that says:

--
Unregister Content Host ""?

Are you sure you want to unregister content host ""?
--

Please note here, the actual name of the host is missing here. Also a javascript error appears in Firebug. Please see the screenshot.

Expected results:


Additional info:

Comment 2 Justin Sherrill 2016-03-15 00:23:12 UTC
Created redmine issue http://projects.theforeman.org/issues/14196 from this bug

Comment 4 Bryan Kearney 2016-03-22 16:02:37 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14196 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|6b86f1da7035a19d9300f0342169b4e9d0a3ed24.

Comment 5 Sachin Ghai 2016-04-18 08:25:55 UTC
Verified with sat6.2 beta snap8.2 

I can successfully unregister a host. Now webUI raises two option if host is registered via subscription manager.

1) Unregister the host as a subscription consumer. Provisioning and configuration information is preserved.

2) Completely deletes the host record and removes all reporting, provisioning, and configuration information. 


when I choose option1, host was unregistered as subscription-manager, but entry still exists on UI under content host as well as under all hosts.

Later, I unregister the same host again, and got only option2, that actually removed the host entry from webui.

Please see attached screenshots

Comment 6 Sachin Ghai 2016-04-18 08:27:11 UTC
Created attachment 1148125 [details]
webUI raises two option on clicking unregister

Comment 7 Sachin Ghai 2016-04-18 08:28:02 UTC
Created attachment 1148126 [details]
host was unregistered successfully from subscription aspect

Comment 8 Brad Buckingham 2016-04-26 12:57:04 UTC
*** Bug 1325526 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2016-07-27 09:04:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.