Bug 1315206 - Can't connect to any display if specifying <CLIENT-MONITOR-ID> greater than the real monitor count
Can't connect to any display if specifying <CLIENT-MONITOR-ID> greater than t...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.8
x86_64 Unspecified
medium Severity medium
: rc
: 6.9
Assigned To: Eduardo Lima (Etrunko)
Virtualization Bugs
:
Depends On:
Blocks: 1339493 1339499
  Show dependency treegraph
 
Reported: 2016-03-07 04:11 EST by xiaodwan
Modified: 2017-03-21 05:17 EDT (History)
9 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-15.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1339493 (view as bug list)
Environment:
Last Closed: 2017-03-21 05:17:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xiaodwan 2016-03-07 04:11:46 EST
Description of problem:
Can't connect to any display if specifying <CLIENT-MONITOR-ID> greater than the real monitor count

Version-Release number of selected component (if applicable):
virt-viewer-2.0-14.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Set <CLIENT-MONITOR-ID> greater than the count of real monitor. For example, if you only have one monitor, you can set it to 1:2.
# cat .config/virt-viewer/settings 

#rhel7.2-back-clone
[d622b6f8-fdee-ad9c-63fe-cac2e9b6200d]
monitor-mapping=1:5
2. Wait for the guest startup and Login into the guest first.
3. lanuch virt-viewer with -f arguments.
# virt-viewer rhel7.2-back-clone -f


Actual results:
"Connected to graphic sever" screen displays and can't connect to any display.


Expected results:
virt-viewer should ignore the monitor-mapping settings and connect to correct displays.

Additional info:
This issue doesn't occur on rhel7.2.
Comment 2 Fabiano Fidêncio 2016-03-07 04:39:21 EST
(In reply to xiaodwan from comment #0)
> Description of problem:
> Can't connect to any display if specifying <CLIENT-MONITOR-ID> greater than
> the real monitor count
> 
> Version-Release number of selected component (if applicable):
> virt-viewer-2.0-14.el6.x86_64
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. Set <CLIENT-MONITOR-ID> greater than the count of real monitor. For
> example, if you only have one monitor, you can set it to 1:2.
> # cat .config/virt-viewer/settings 
> 
> #rhel7.2-back-clone
> [d622b6f8-fdee-ad9c-63fe-cac2e9b6200d]
> monitor-mapping=1:5
> 2. Wait for the guest startup and Login into the guest first.
> 3. lanuch virt-viewer with -f arguments.
> # virt-viewer rhel7.2-back-clone -f
> 
> 
> Actual results:
> "Connected to graphic sever" screen displays and can't connect to any
> display.
> 
> 
> Expected results:
> virt-viewer should ignore the monitor-mapping settings and connect to
> correct displays.
> 
> Additional info:
> This issue doesn't occur on rhel7.2.

I'd say this issue doesn't occur on rhel7.2 YET.
I'd keep this bug (and the other one related to monitor config) in the radar, because most likely it will start happening there as well.

Anyways, proposed patch: http://www.redhat.com/archives/virt-tools-list/2016-March/msg00046.html
Comment 3 Mike McCune 2016-03-28 19:44:20 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 xiaodwan 2016-12-07 01:04:27 EST
I verfied this bug with virt-viewer-2.0-17.el6.x86_64.

And virt-viewer can ignore the invalid settings and open guest correctly.

So move the bug from ON_QA to VERIFIED.
Comment 7 errata-xmlrpc 2017-03-21 05:17:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0587.html

Note You need to log in before you can comment on or make changes to this bug.