Bug 1315225 - firefox build failure on ppc64le/arm64
firefox build failure on ppc64le/arm64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
24
ppc64le All
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
AcceptedFreezeException
:
: 1320953 (view as bug list)
Depends On:
Blocks: PPCTracker ARM64/F-ExcludeArch-aarch64 F24BetaFreezeException
  Show dependency treegraph
 
Reported: 2016-03-07 04:47 EST by Ngo Than
Modified: 2016-05-03 14:05 EDT (History)
9 users (show)

See Also:
Fixed In Version: firefox-46.0-4.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-03 14:05:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ngo Than 2016-03-07 04:47:21 EST
firefox-45.0-4 doesn't build on ppc64le in f24, it breaks with following errors:

Executing /builddir/build/BUILD/firefox-45.0/firefox-45.0/objdir/dist/bin/xpcshell -g /builddir/build/BUILD/firefox-45.0/firefox-45.0/objdir/dist/bin/ -a /builddir/build/BUILD/firefox-45.0/firefox-45.0/objdir/dist/bin/ -f /builddir/build/BUILD/firefox-45.0/firefox-45.0/toolkit/mozapps/installer/precompile_cache.js -e precompile_startupcache("resource://gre/");
No such property on self-hosted object: undefined
Traceback (most recent call last):
  File "/builddir/build/BUILD/firefox-45.0/firefox-45.0/toolkit/mozapps/installer/packager.py", line 406, in <module>
    main()
  File "/builddir/build/BUILD/firefox-45.0/firefox-45.0/toolkit/mozapps/installer/packager.py", line 400, in main
    args.source, gre_path, base)
  File "/builddir/build/BUILD/firefox-45.0/firefox-45.0/toolkit/mozapps/installer/packager.py", line 161, in precompile_cache
    errors.fatal('Error while running startup cache precompilation')
  File "/builddir/build/BUILD/firefox-45.0/firefox-45.0/python/mozbuild/mozpack/errors.py", line 103, in fatal
    self._handle(self.FATAL, msg)
  File "/builddir/build/BUILD/firefox-45.0/firefox-45.0/python/mozbuild/mozpack/errors.py", line 98, in _handle
    raise ErrorMessage(msg)
mozpack.errors.ErrorMessage: Error: Error while running startup cache precompilation


For more infos please take a look at:
 http://ppc.koji.fedoraproject.org/kojifiles/work/tasks/2214/3202214/build.log
Comment 1 Peter Robinson 2016-04-09 15:59:10 EDT
And aarch64 http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=366928
Comment 2 Fedora Blocker Bugs Application 2016-04-09 16:00:10 EDT
Proposed as a Freeze Exception for 24-beta by Fedora user pbrobinson using the blocker tracking app because:

 Secondary architecture. Primary browser must be working.
Comment 3 Martin Stransky 2016-04-11 03:46:03 EDT
I guess it's caused by gcc6 compiler. I see the builds went fine some time ago but all builds fail now.
Comment 4 Kamil Páral 2016-04-18 12:53:04 EDT
Discussed at today's blocker review meeting [1]. Voted as AcceptedFreezeException (Beta) - Firefox is the default browser for most desktops, and this bug prevents its inclusion in secondary-arch images. issues that seriously affect the compose of secondary arch deliverables generally qualify for FE status.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-04-18
Comment 5 Fedora Update System 2016-04-18 15:31:42 EDT
firefox-45.0.2-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cebfb38250
Comment 6 Peter Robinson 2016-04-19 08:12:23 EDT
(In reply to Fedora Update System from comment #5)
> firefox-45.0.2-2.fc24 has been submitted as an update to Fedora 24.
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-cebfb38250

The firefox-45.0.2-2.fc24 build doesn't fix this problem, at least on aarch64

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=3508596
Comment 7 Peter Robinson 2016-04-19 09:35:51 EDT
Doesn't build on Power64 either
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3310296
Comment 8 Martin Stransky 2016-04-19 15:58:11 EDT
Looks like wrong memory layout here:

Assertion failure: size % pageSize == 0, at /root/rpmbuild/BUILD/firefox-45.0.2/firefox-45.0.2/js/src/gc/Memory.cpp:757

Thread 1 "js" received signal SIGSEGV, Segmentation fault.
0x0000000020a503e0 in js::gc::ProtectPages (p=<optimized out>, size=<optimized out>)
    at /root/rpmbuild/BUILD/firefox-45.0.2/firefox-45.0.2/js/src/gc/Memory.cpp:757
757	    MOZ_ASSERT(size % pageSize == 0);
Comment 9 Peter Robinson 2016-04-19 17:16:28 EDT
(In reply to Martin Stransky from comment #8)
> Looks like wrong memory layout here:

Both aarch64 and Powwer64 are 64k page sizes
Comment 10 Martin Stransky 2016-04-21 07:29:39 EDT
*** Bug 1320953 has been marked as a duplicate of this bug. ***
Comment 11 Martin Stransky 2016-04-26 10:20:59 EDT
Looks like the recent -O3 optimization is too aggressive/buggy on gcc6 for aarch64. We need to switch to -O2 temporary for JS engine.
Comment 12 Dan Horák 2016-04-27 04:09:35 EDT
still getting the failure on ppc64le with firefox-46.0-2.fc24
Comment 13 Martin Stransky 2016-04-27 05:27:04 EDT
Added fix to firefox-46.0-4 - please test on ppc.koji.
Comment 14 Peter Robinson 2016-04-27 05:28:29 EDT
(In reply to Martin Stransky from comment #13)
> Added fix to firefox-46.0-4 - please test on ppc.koji.

Do you mean -3 as there's no -4 there
http://koji.fedoraproject.org/koji/packageinfo?packageID=37
Comment 15 Martin Stransky 2016-04-27 05:31:50 EDT
No, I really mean -4 which goes to koji now. Unfortunately koji don't allow me to cancel already submitted builds.
Comment 16 Peter Robinson 2016-04-27 05:34:35 EDT
(In reply to Martin Stransky from comment #15)
> No, I really mean -4 which goes to koji now. Unfortunately koji don't allow
> me to cancel already submitted builds.

Yes, it does: "koji cancel <parent task ID>"
Comment 18 Ngo Than 2016-04-27 06:54:52 EDT
i confirm the fix. the latest firefox-46.0-4 built fine on ppc now
Comment 19 Peter Robinson 2016-04-27 07:29:11 EDT
So Power and aarch64 look fine. s390 and s390x are still failing.

s390x failure http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2195391
Comment 20 Peter Robinson 2016-04-27 08:14:33 EDT
I believe we also need similar fixes for thunderbird/xulrunner
Comment 21 Dan Horák 2016-04-27 08:35:21 EDT
(In reply to Peter Robinson from comment #19)
> So Power and aarch64 look fine. s390 and s390x are still failing.
> 
> s390x failure http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2195391

this is a buildroot issue with f25 not being fullu up-to-date
Comment 22 Peter Robinson 2016-04-27 14:07:42 EDT
Can we get this submitted as an update for F-24 please
Comment 23 Peter Robinson 2016-04-27 14:08:18 EDT
Sorry, wrong needinfo, Martin it was for you
Comment 24 Fedora Update System 2016-04-27 15:14:31 EDT
firefox-46.0-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0f939ef633
Comment 25 Martin Stransky 2016-04-28 04:58:53 EDT
Why do you needinfo me when you do the update yourself.
Comment 26 Peter Robinson 2016-04-28 05:14:37 EDT
(In reply to Martin Stransky from comment #25)
> Why do you needinfo me when you do the update yourself.

I put the needinfo on about 2hrs before I did the update
Comment 27 Fedora Update System 2016-04-28 12:26:05 EDT
firefox-46.0-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0f939ef633
Comment 28 Fedora Update System 2016-05-03 14:05:45 EDT
firefox-46.0-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.