This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1315238 - Typo in /etc/virt-who.d/template.conf
Typo in /etc/virt-who.d/template.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Radek Novacek
Eko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 05:27 EST by Kenny Tordeurs
Modified: 2016-11-30 19:36 EST (History)
2 users (show)

See Also:
Fixed In Version: virt-who-0.17-1.el7
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:08:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenny Tordeurs 2016-03-07 05:27:21 EST
Description of problem:
There is a type in the automatically generated template.conf file for virt-who

~~~
#encrypted_password vs #encryped_password
~~~

Version-Release number of selected component (if applicable):
# rpm -qa | grep virt-who
~~~
virt-who-0.14-9.el7.noarch
~~~

Actual results:
# cat /etc/virt-who.d/template.conf
~~~
## This is a template for virt-who configuration files. Please see
## virt-who-config(5) manual page for detailed information.
##
## virt-who checks all files in /etc/virt-who.d/ if they're valid ini-like
## files and uses them as configuration. Each file might contain more configs.
##
## You can uncomment and fill following template or create new file with
## similar content.

#[config name]
#type=               ; insert one of libvirt/esx/hyperv/rhevm/vdsm/fake
#server=             ; insert hostname or ip address of the server to connect to
#username=           ; username for server authentication
#password=           ; password for server authentication
#encryped_password=  ; password encrypted using virt-who-password utility
#owner=              ; owner for use with SAM, Customer Portal, or Satellite 6
#env=                ; environment for use with SAM, Customer Portal, or Satellite 6
#hypervisor_id=      ; how will be the hypervisor identified, one of: uuid, hostname, hwuuid

## For complete list of options, see virt-who-config(5) manual page.

## Terse version of the config template:
#[config name]
#type=
#server=
#username=
#password=
#encryped_password=
#owner=
#env=
#hypervisor_id=
~~~

Expected results:
~~~
## This is a template for virt-who configuration files. Please see
## virt-who-config(5) manual page for detailed information.
##
## virt-who checks all files in /etc/virt-who.d/ if they're valid ini-like
## files and uses them as configuration. Each file might contain more configs.
##
## You can uncomment and fill following template or create new file with
## similar content.

#[config name]
#type=               ; insert one of libvirt/esx/hyperv/rhevm/vdsm/fake
#server=             ; insert hostname or ip address of the server to connect to
#username=           ; username for server authentication
#password=           ; password for server authentication
#encrypted_password=  ; password encrypted using virt-who-password utility
#owner=              ; owner for use with SAM, Customer Portal, or Satellite 6
#env=                ; environment for use with SAM, Customer Portal, or Satellite 6
#hypervisor_id=      ; how will be the hypervisor identified, one of: uuid, hostname, hwuuid

## For complete list of options, see virt-who-config(5) manual page.

## Terse version of the config template:
#[config name]
#type=
#server=
#username=
#password=
#encrypted_password=
#owner=
#env=
#hypervisor_id=
~~~

Additional info:
Comment 2 Radek Novacek 2016-03-08 10:40:18 EST
This issue is addressed upstream and will be fixed by virt-who rebase.
Comment 3 Radek Novacek 2016-05-17 09:03:08 EDT
Fixed in virt-who-0.17-1.el7.
Comment 5 Eko 2016-05-30 04:13:18 EDT
Verified in virt-who-0.17-1.el7

# grep "encryped" /etc/virt-who.d/template.conf

# grep "encrypted" /etc/virt-who.d/template.conf
template.conf:#encrypted_password=  ; password encrypted using virt-who-password utility
template.conf:#encrypted_password=
Comment 7 errata-xmlrpc 2016-11-04 01:08:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2387.html

Note You need to log in before you can comment on or make changes to this bug.