Bug 1315250 - task export of running tasks fills "Ended at: " for just running subtasks
task export of running tasks fills "Ended at: " for just running subtasks
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Tasks Plugin (Show other bugs)
6.1.6
All Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 06:16 EST by Pavel Moravec
Modified: 2017-08-04 09:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-04 09:19:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Moravec 2016-03-07 06:16:51 EST
Description of problem:
Taking task export when some task runs a sub-task, the sub-task has "Ended at: " filled by the current time.

"Ended at: " should be empty, though. Since the sub-task hasnt finished yet.


Version-Release number of selected component (if applicable):
Sat6.1.7


How reproducible:
100%


Steps to Reproduce:
1. Kick off some longer task (i.e. sync rhel5-7 base repo)
2. Take task export:
foreman-rake foreman_tasks:export_tasks
3. check the task in task export is still pending, but a sub-task running (like  Actions::Pulp::Consumer::SyncNode for the long sync) has filled "Ended at: " by the current time.


Actual results:
3. "Ended at: " for the sub-task contains time when the task export was running


Expected results:
3. "Ended at: " should be empty for the sub-task being executed / pending.


Additional info:
Comment 2 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 3 Bryan Kearney 2016-07-26 11:33:26 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 5 Bryan Kearney 2017-08-04 09:19:01 EDT
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Note You need to log in before you can comment on or make changes to this bug.