Bug 1315251 - user should know if LDAP server is not accessible
user should know if LDAP server is not accessible
Status: CLOSED WONTFIX
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI (Show other bugs)
2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3
Assigned To: Soumya Deb
sds-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 06:20 EST by Martin Kudlej
Modified: 2017-03-23 00:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-23 00:11:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2016-03-07 06:20:33 EST
Description of problem:
I think user should know if Skyring cannot access LDAP server.
I've configured Skyring with LDAP but when LDAP server is not accessible I as user don't know about that and I should look into logs.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.8-10.el7.x86_64
rhscon-ui-0.0.19-1.el7.noarch
rhscon-ceph-0.0.6-10.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install skyring and configure ldap
2. shutdown machine with ldap
3. try to search ldap user from UI and watch potential error messages in UI

Actual results:
User doesn't know about problems in LDAP.

Expected results:
In case of any error in Skyring because of LDAP there will be error message in UI.
Comment 3 Nishanth Thomas 2016-06-21 09:00:46 EDT
Need to implement a 'Test' button to verify the LDAP is reachable
Comment 4 Jeff Applewhite 2016-06-21 09:01:57 EDT
need test LDAP connection button to resolve

Note You need to log in before you can comment on or make changes to this bug.