This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1315254 - [SMB] smbd core dumps are always truncated to 16M
[SMB] smbd core dumps are always truncated to 16M
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.3
Assigned To: Raghavendra Talur
Vivek Das
: ZStream
Depends On:
Blocks: 1299184
  Show dependency treegraph
 
Reported: 2016-03-07 06:36 EST by Raghavendra Talur
Modified: 2016-06-23 01:37 EDT (History)
8 users (show)

See Also:
Fixed In Version: samba-4.4.3-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:37:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 11907 None None None 2016-05-06 09:38 EDT

  None (edit)
Description Raghavendra Talur 2016-03-07 06:36:06 EST
Description of problem:
We find that smbd cores are always truncated to 16M. It is already fixed in Samba master and we should get it in next downstream release.
Comment 2 Raghavendra Talur 2016-03-08 07:12:55 EST
Some more details about the bug:

Although this has been taken from some other bug, we find a similar message on opening the core file.

root@samba4-ad2:smbd# gdb core.27767
GNU gdb (GDB) Red Hat Enterprise Linux (7.2-75.el6)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
BFD: Warning: /var/log/samba/cores/smbd/core.27767 is truncated: expected core file size >= 33017856, found: 16830464.
BFD: Warning: /var/log/samba/cores/smbd/core.27767 is truncated: expected core file size >= 33017856, found: 16830464.
Reading symbols from /usr/sbin/smbd...Reading symbols from /usr/lib/debug/usr/sbin/smbd.debug...done.


Note found: 16830464. This is the 16M limit the core is truncated to.
Comment 4 Raghavendra Talur 2016-04-25 02:30:08 EDT
Anoop C S has already RCA'ed the bug. We are working on changes required in init files and systemd unit files to fix in RHEL6 and RHEL7. We will have fix merged for this by end of this week.
Comment 5 Vivek Das 2016-05-10 01:37:35 EDT
[RHEL7] : I am able to crash smbd and produce core dump file of 160MB without getting truncated to 16MB. So rhel7 seemed fine.

[RHEL6] : Even after vdsm work around the core file is not getting dumped in any of the below locations i.e /var/log/core & /var/log/samba/cores/smbd.

version
========
samba-client-4.4.3-2.el6rhs.x86_64

Verification on RHEL6 failed.
Comment 6 Vivek Das 2016-05-16 02:15:12 EDT
Verified in RHEL6 & RHEL7 over version samba-client-4.4.3-3.el7rhgs.x86_64 and smbd core dumps are not getting truncated.

Marking it as verified.
Comment 8 errata-xmlrpc 2016-06-23 01:37:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1248

Note You need to log in before you can comment on or make changes to this bug.