Bug 1315265 - New puppet modules are not sync between satellite and capsules since the update to satellite 6.1.5
New puppet modules are not sync between satellite and capsules since the upda...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Configuration Management (Show other bugs)
6.1.5
Unspecified Linux
urgent Severity urgent (vote)
: Beta
: --
Assigned To: Justin Sherrill
Sachin Ghai
: PrioBumpQA, Regression, Triaged
Depends On: 1293902
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 06:52 EST by Brad Buckingham
Modified: 2016-07-27 05:04 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293902
Environment:
Last Closed: 2016-07-27 05:04:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 08:24:38 EDT

  None (edit)
Comment 3 Justin Sherrill 2016-03-07 19:27:36 EST
This issue seems related to the node functionality and gofer parts of capsule syncing.  In Satellite 6.2 we are no longer using these parts of pulp to perform the syncing.  

Moving to modified.
Comment 5 Sachin Ghai 2016-04-05 03:41:15 EDT
Verified with sat6.2 beta snap6

I can sync puppet modules between satellite and capsule. 

- I created a puppet_cv and added 'apache' and 'nova' modules.
- published/promoted them to 'test' env
- ran capsule sync as below. 

on satellite server: Following two modules are synced
====================
[root@cloud-qe-15 ~]# getenforce 
Enforcing
[root@cloud-qe-15 ~]# grep '"version":' /etc/puppet/environments/KT_Default_Organization_Test_puppet_cv_8/modules/apache/metadata.json 
  "version": "1.8.1",
[root@cloud-qe-15 ~]# grep '"version":' /etc/puppet/environments/KT_Default_Organization_Test_puppet_cv_8/modules/nova/metadata.json 
  "version": "7.0.0",


[root@cloud-qe-15 ~]# hammer -u admin -p changeme capsule content synchronize --id 2
[............................................................................................................................................] [100%]



on capsule, after sync:
=======================

[root@cloud-qe-7 ~]# getenforce 
Enforcing
[root@cloud-qe-7 ~]# grep '"version":' /etc/puppet/environments/KT_Default_Organization_Test_puppet_cv_8/modules/apache/metadata.json
  "version": "1.8.1",
[root@cloud-qe-7 ~]# grep '"version":' /etc/puppet/environments/KT_Default_Organization_Test_puppet_cv_8/modules/nova/metadata.json 
  "version": "7.0.0",
Comment 7 errata-xmlrpc 2016-07-27 05:04:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.