Bug 1315279 - Server fails to shutdown if vdb with REST service generation is deployed
Server fails to shutdown if vdb with REST service generation is deployed
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.3.0
Unspecified Unspecified
high Severity urgent
: ER1
: 6.3.0
Assigned To: Van Halbert
Filip Elias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 07:00 EST by Filip Elias
Modified: 2016-08-24 07:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
DV 6.3 ER1
Last Closed: 2016-08-24 07:44:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
VDB (848 bytes, text/plain)
2016-03-07 07:00 EST, Filip Elias
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-4024 Major Resolved Server fails to shutdown if vdb with REST service generation is deployed 2016-11-21 05:02 EST

  None (edit)
Description Filip Elias 2016-03-07 07:00:12 EST
Created attachment 1133716 [details]
VDB

DV sometimes won't stop if vdb with REST service generation is deployed.

Steps to reproduces:
1. Create a clean copy of DV 6.3 ER1
2. Deploy nosource-vdb.xml (in the attachment) using CLI: deploy /pathtovdb/nosource-vdb.xml
3. Shutdown the server using CLI: shutdown

Server log is in the associated jira.

When the server is killed and started again, it will stop correctly.

The issue is random. Server fails to stop in 50% of cases.
Comment 1 Alex Szczuczko 2016-03-07 07:06:24 EST
I was thinking this might be caused by a race condition involving a non-daemon thread, which I guess must be introduced in the scenario you identify. Just a guess. Maybe jconsole or a debugger could be used to check.
Comment 2 JBoss JIRA Server 2016-03-09 10:46:47 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-4024 to Resolved
Comment 3 Van Halbert 2016-03-09 10:51:04 EST
This is included in ER1.2 build.

Note You need to log in before you can comment on or make changes to this bug.