Bug 1315314 - BaseLineMean is set to NaN
BaseLineMean is set to NaN
Status: CLOSED ERRATA
Product: JBoss Operations Network
Classification: JBoss
Component: Database (Show other bugs)
JON 3.3.4
Unspecified Unspecified
medium Severity medium
: CR02
: JON 3.3.8
Assigned To: Michael Burman
Filip Brychta
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 08:10 EST by Yogesh
Modified: 2017-05-12 04:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-16 13:44:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1469933 None None None 2016-03-10 11:46 EST

  None (edit)
Description Yogesh 2016-03-07 08:10:34 EST
Description of problem:

In the ByteMan logging of JBoss ON server there are some BaseLineMean values which are set to Nan. Main reason for it seems that, in the class "org.rhq.core.domain.measurement.MeasurementBaseline" all values are defined with "nullable = false"
Because of these Nan there are multiple WARN messages in the JBossON server logs.

Version-Release number of selected component (if applicable):
3.3.4
How reproducible:
Configure Oracle database with JBossON. Configure ByteMan Logging as per Article https://access.redhat.com/solutions/1469933. 


Steps to Reproduce:
1.
2.
3.

Actual results:
Nan values are tried to be inserted in the database.
Expected results:
NaN values shuold not be inserted in Oracle.
Additional info:
Comment 12 Simeon Pinder 2017-02-08 01:03:16 EST
Moving to ON_QA as available for test with the latest build:

JON 3.3.8 CR01 artifacts are available for test from here:
http://download.eng.bos.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/114/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip
 *Note: jon-server-patch-3.3.0.GA.zip maps to CR01 build of
 jon-server-3.3.0.GA-update-08.zip.

https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=537179
Comment 13 Simeon Pinder 2017-02-10 19:19:34 EST
Moving to ON_QA as available for testing with the following build:
 http://download.eng.bos.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/117/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip
 *Note: jon-server-patch-3.3.0.GA.zip maps to CR02 build of
 jon-server-3.3.0.GA-update-08.zip.
Comment 15 errata-xmlrpc 2017-02-16 13:44:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2017-0285.html

Note You need to log in before you can comment on or make changes to this bug.