Bug 1315336 - Regression: screen update breaks screen protocol
Regression: screen update breaks screen protocol
Status: CLOSED DUPLICATE of bug 1253697
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: screen (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Josef Ridky
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 08:48 EST by Jaroslav Škarvada
Modified: 2017-02-07 07:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-07 07:54:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2016-03-07 08:48:38 EST
Description of problem:
It seems that the screen update between RHEL-7.1 - RHEL-7.2 broke the screen protocol. This can cause serious trouble to customers/users. Imagine scenarios where there are long term running processes in screens. By performing the screen update, these screens are no longer accessible and the processes running there are inaccessible.

What worse, the screen client hangs upon attempt to connect to the screen server and it is not possible to terminate it (i.e. it doesn't respond to CTRL+C). The only way how to terminate it is to login via another shell and kill the processes by hand.

This causes really bad user experience and can cause serious harm. What worse, only the release from the NVR was bumped which doesn't signal that the update uses incompatible protocol. Not counting the scenarios where the update process is initiated from the screen itself and user disconnects from the screen during the update.

Version-Release number of selected component (if applicable):
screen-4.1.0-0.19.20120314git3c2946.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. install screen-4.1.0-0.19.20120314git3c2946.el7.x86_64
2. screen
3. disconnect from screen
4. update to screen-4.1.0-0.21.20120314git3c2946.el7.x86_64
5. screen -r

Actual results:
screen client hangs, screen server not accessible

Expected results:
screen session reconnected

Additional info:
I guess the protocol was broken by some backport. I think we should provide specific screen protocols downstream hacks, to make new screen clients backward compatible to the older server.
Comment 1 Jaroslav Škarvada 2016-03-07 08:49:30 EST
Screen downgrade make the running screens again accessible.
Comment 3 Jaroslav Škarvada 2016-03-07 11:56:44 EST
Probably dupe of bug 1253697, maybe fixed by screen-4.1.0-0.22.20120314git3c2946.el7, but I haven't checked it.
Comment 4 Josef Ridky 2017-02-07 07:54:27 EST
I have check this issue in RHEL-7.3 with screen package in the latest version in RHEL (screen-4.1.0-0.23.20120314git3c2946.el7_2).

This issue is not presented here. It looks like it was solved in bugzilla #1253697. This solution is already presented in RHEL-7.3 branch.

Because of this, I am closing this bugzilla as DUPLICATED of 1253697.

Feel free to reopen it in case you think, that described issue still persist.

*** This bug has been marked as a duplicate of bug 1253697 ***

Note You need to log in before you can comment on or make changes to this bug.