Bug 1315342 - XDMCP gnome session unlock screen fails
XDMCP gnome session unlock screen fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdm (Show other bugs)
7.2
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 08:57 EST by Christoph
Modified: 2016-11-07 05:49 EST (History)
4 users (show)

See Also:
Fixed In Version: gdm-3.14.2-18.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:40:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journalctl output of gdm with debuglevel (17.14 KB, text/plain)
2016-03-07 08:57 EST, Christoph
no flags Details
don't try to change vts on an xdmcp session (2.95 KB, patch)
2016-08-01 11:47 EDT, Ray Strode [halfline]
no flags Details | Diff

  None (edit)
Description Christoph 2016-03-07 08:57:15 EST
Created attachment 1133788 [details]
journalctl output of gdm with debuglevel

Description of problem:

remote xdmcp session can't unlock the screen


Version-Release number of selected component (if applicable):

gdm-3.14.2-12.el7.x86_64
gnome-session-3.14.0-4.el7.x86_64
systemd-219-19.el7_2.4.x86_64


How reproducible:

always.


Steps to Reproduce:

1. install gnome desktop (yum install gnome-desktop)
2. add tcp listener to gdm by adding DisallowTCP=false to /etc/gdm/custom.conf
3. restart gdm (systemctl restart gdm.service)
4. access machine using xdmcp (on a linux workstation: Xephyr :1 -ac -br -screen 1024x768 -reset -terminate -query server.example.com)
5. log into gdm (using the gnome classic session)
6. see gnome desktop, so far so good.
7. lock the remote screen using the system menu in the top right corner of the gnome shell, lock icon (or wait till the automatic lock kicks in)
8. the gnome curtain displays. 
9. hit enter, password prompt shows
10. enter password. Password prompt shows again. no error message.

Actual results:

can't unlock a remote gnome lock screen.


Expected results:

unlock and desktop shows again.


Additional info:

Unlocking the session using loginctl works.

A locally (as in sitting in front of the servers keyboard) logged in user can lock and unlock the screen.


Running gdm with debug enabled here is a shortened version of journalctl, a longer version is attached

gdm[16832]: GdmSessionWorker: state AUTHENTICATED
gdm[16832]: GdmSessionWorker: state AUTHORIZED
gdm[16832]: GdmSessionWorker: state ACCREDITED
gdm[16832]: GdmCommon: process (pid:18514) done (status:0)
gdm[16832]: GdmSession: Emitting 'reauthenticated' signal
gdm[16832]: GLib: g_variant_new_string: assertion 'string != NULL' failed
gdm[16832]: GdmManager: logind 'ActivateSessionOnSeat' org.freedesktop.login1.NoSuchSeat raised:
gdm[16832]: GDBus.Error:org.freedesktop.login1.NoSuchSeat: No seat '[Invalid UTF-8]' known
gdm[16832]: GdmManager: unable to activate session: 26



The glib error and the invalid utf8 look suspicious.
Comment 4 Ray Strode [halfline] 2016-08-01 11:47 EDT
Created attachment 1186452 [details]
don't try to change vts on an xdmcp session
Comment 6 Michael Boisvert 2016-09-01 11:40:40 EDT
Following the steps in the description I was able to successfully log in/out/in of a XDMCP gnome session on gdm-3.14.2-18.el7.

Verified.
Comment 8 errata-xmlrpc 2016-11-04 02:40:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2451.html

Note You need to log in before you can comment on or make changes to this bug.