Bug 1315349 - dnf-makecache.service fills journal with useless lines because of verbose option
Summary: dnf-makecache.service fills journal with useless lines because of verbose option
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 23
Hardware: Unspecified Linux
unspecified
low
Target Milestone: ---
Assignee: packaging-team-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-07 14:20 UTC by Edgar Hoch
Modified: 2016-04-13 07:22 UTC (History)
5 users (show)

Fixed In Version: dnf-1.1.8-1.fc24 dnf-1.1.8-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 07:22:08 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "journalctl --since=12:00 -u dnf-makecache" today (69.12 KB, text/plain)
2016-03-07 14:20 UTC, Edgar Hoch
no flags Details

Description Edgar Hoch 2016-03-07 14:20:49 UTC
Created attachment 1133789 [details]
Output of "journalctl --since=12:00 -u dnf-makecache" today

Description of problem:
dnf-makecache.service is called every hour by dnf-makecache.timer.
It fills the journal with many hundred lines of nearly useless data every hour because dnf is called with the verbose option "-v".

/usr/lib/systemd/system/dnf-makecache.service contains the line

ExecStart=/usr/bin/dnf -v makecache timer

I don't see useful information on the verbose output of dnf makecache that is useful and needed every hour in the journal log. Verbose output is useful for debugging, but not for automatic background scripts.

I assume that error messages will be printed without option "-v" too (but I don't know how to test it).

When journal is filled with data that doesn't contain useful information for the system administrator, then this rises the risk that important logged messages are overlooked.

I suggest to remove option "-v" in the ExecStart= line.


Version-Release number of selected component (if applicable):
dnf-1.1.6-2.fc23.noarch

How reproducible:
Always

Comment 1 Fedora Update System 2016-04-06 14:38:45 UTC
dnf-plugins-core-0.1.20-1.fc24 dnf-1.1.8-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5dae5d2add

Comment 2 Fedora Update System 2016-04-07 10:02:10 UTC
dnf-1.1.8-1.fc23 dnf-plugins-core-0.1.20-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ddeabfcfe6

Comment 3 Fedora Update System 2016-04-07 16:54:22 UTC
dnf-1.1.8-1.fc24, dnf-plugins-core-0.1.20-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5dae5d2add

Comment 4 Fedora Update System 2016-04-08 16:59:12 UTC
dnf-1.1.8-1.fc24, dnf-plugins-core-0.1.20-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2016-04-08 20:51:31 UTC
dnf-1.1.8-1.fc23, dnf-plugins-core-0.1.20-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ddeabfcfe6

Comment 6 Fedora Update System 2016-04-13 07:21:39 UTC
dnf-1.1.8-1.fc23, dnf-plugins-core-0.1.20-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.