Bug 1315365 - User cannot see default download policy value when creating a repo
User cannot see default download policy value when creating a repo
Status: CLOSED DUPLICATE of bug 1322620
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: David Davis
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 09:51 EST by Justin Sherrill
Modified: 2016-03-31 10:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 10:53:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2016-03-07 09:51:00 EST
Description of problem:

When creating a repo within the web UI, there are 4 options:

**BLANK**
on demand
background
immediate

If the user leaves it blank, the server default is selected, but:

a) this is not obvious as other fields on this page do not behave that way
b) There isn't any way for the user to know what the default is

Version-Release number of selected component (if applicable):
6.2.0 snap1

How reproducible:
always


Additional info:

A description for each policy on that page would be good to.
Comment 2 Roman Plevka 2016-03-25 20:42:17 EDT
in 6.2.0 Snap5.1, leaving the download_policy blank doesn't pass the validation and returns:
"Download policy is not included in the list".

The weird side effect is that the invalid field with the error message is not highlighted in red so it's hard to spot why the validation failed.

The error is most probably caused by this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1320311
Comment 3 David Davis 2016-03-31 10:53:09 EDT

*** This bug has been marked as a duplicate of bug 1322620 ***

Note You need to log in before you can comment on or make changes to this bug.