Bug 1315366 - Possible guidance to use "pcs node maintenance --all" instead of "pcs cluster standby --all"
Possible guidance to use "pcs node maintenance --all" instead of "pcs cluster...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs (Show other bugs)
7.2
Unspecified Linux
medium Severity unspecified
: rc
: ---
Assigned To: Tomas Jelinek
cluster-qe@redhat.com
:
Depends On: 1245721 1247088
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 09:52 EST by Jan Pokorný
Modified: 2016-10-21 10:25 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1245721
Environment:
Last Closed: 2016-10-21 10:25:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2016-03-07 09:52:14 EST
+++ This bug was initially created as a clone of Bug #1245721 +++

I don't think there is an "ask interactively" precedence in pcs
(putting auth aside), but in case of any resource running (or just
defined ... or just always) it would be good to ask the user if she
indeed wants "pcs cluster standby --all" or rather enable the maintenance
mode.  Or just apply this logic without asking as this should definitely
be more sane thing to do.

--- Additional comment from Jan Pokorný on 2015-08-28 19:13:21 CEST ---

In case you don't like "standby --all" -> maintenance mode trigger
proposal, you may, at least, consider translating that command into
"pcs property set stop_all_resources=true" that would likely avoid 
inevitable issue with iterated switch toggling -- evacuation
of the resources to the rest of living nodes (until they are
standby'd as well) connected with unnecessary and unhelpful
utilization peaks there (there are some risks implied).


[...]

--- Additional comment from Jan Pokorný on 2015-09-01 17:11:08 CEST ---

[...] I was talking about possibly bad behavior of "pcs cluster
standby --all" which could not be translated into enabling maintenance
mode as pcs hasn't be able to do that yet.  With this bug resolved
it will be, hence proposing translating that command to maintenance
mode enablement (implicitly or explicitly).  Is it more clear now?
Comment 1 Jan Pokorný 2016-03-07 09:54:56 EST
Promoting aside suggestion to an RFE on its own as it remained unheard.

Note that the equivalent sanity confirmation is relevant to both CLI
and GUI.
Comment 3 Tomas Jelinek 2016-10-21 10:25:59 EDT
The "pcs cluster standby" command puts nodes into standby mode. It would be very counterintuitive and confusing if it did something else when --all flag was specified. And this would not be fixed by documenting such behavior. Also what if the user really wants to put all the nodes into standby mode? Is pcs so much clever than the user that it can deny him to do that? I do not think so.

You can argue that pcs could ask interactively what is it that the user really wants to do. But user must have typed the command in the first place, is not that a manifestation of desired action already? I think it is.

The issue with moving resources around cluster while putting several / all nodes into standby mode is already covered in bz1315992.

Therefore I am closing this as not a bug.

Note You need to log in before you can comment on or make changes to this bug.