Bug 1315376 - One server shown twice in discovery queue
One server shown twice in discovery queue
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 7 (Show other bugs)
JON 3.3.5
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Simeon Pinder
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 10:23 EST by Hayk Hovsepyan
Modified: 2016-03-07 10:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 10:24:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2016-03-07 10:23:51 EST
Description of problem:
When server is started in security mode (2-way SSL) and then restarted in unsecure mode, it shows two servers in discovery queue.

Version-Release number of selected component (if applicable):
Version 3.3
Update-03
DR01 
jon-plugin-pack-eap-3.3.0.GA.zip

How reproducible:
always

Steps to Reproduce:
1. Configure EAP7  server to 2-way SSL and start it.
2. Agent monitoring EAPs is running and registered with the server.
3. In discovery queue of JON server it will show this server.
4. Stop EAP7 server and start it in unsecure mode.
5. In discovery queue of JON server it will show 2 servers with 2 different ports.
6. Import both servers.
7. It will show one of servers UP and the second on as DOWN.

Discussed with JON developers, this behavior is according to design.
Comment 1 Hayk Hovsepyan 2016-03-07 10:44:32 EST
Similar to https://bugzilla.redhat.com/show_bug.cgi?id=1315380

Note You need to log in before you can comment on or make changes to this bug.