Bug 1315394 - rebase to 12.0.2
rebase to 12.0.2
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
8.0 (Liberty)
x86_64 Linux
unspecified Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Lee Yarwood
Prasanth Anbalagan
: Rebase
: 1311634 (view as bug list)
Depends On:
Blocks: 1194008
  Show dependency treegraph
 
Reported: 2016-03-07 10:57 EST by Lee Yarwood
Modified: 2016-04-07 17:34 EDT (History)
15 users (show)

See Also:
Fixed In Version: openstack-nova-12.0.2-1.el7ost
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
This package rebases Compute (nova) to version 12.0.2, and includes a number of updates: - Propagate qemu-img errors to compute manager - Fix evacuate support with Nova cells v1 - libvirt: set libvirt.sysinfo_serial='none' for virt driver tests - XenAPI: Workaround for 6.5 iSCSI bug - Change warn to debug logs when migration context is missing - Imported Translations from Zanata - libvirt: Fix/implement revert-resize for RBD-backed images - Ensure Glance image 'size' attribute is 0, not 'None' - Add retry logic for detaching device using LibVirt - Spread allocations of fixed ips - Apply scheduler limits to Exact* filters - Replace eventlet-based raw socket client with requests - VMware: Handle image size correctly for OVA and streamOptimized images - XenAPI: Cope with more Cinder backends - ports & networks gather should validate existance - Disable IPv6 on bridge devices - Validate translations - Fix instance not destroyed after successful evacuation
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:34:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Yarwood 2016-03-07 10:57:39 EST
Description of problem:

Rebase openstack-nova to 12.0.2

http://lists.openstack.org/pipermail/openstack-announce/2016-March/001005.html
Comment 2 Lee Yarwood 2016-03-08 07:19:26 EST
- Propagate qemu-img errors to compute manager
- Fix evacuate support with Nova cells v1
- libvirt: set libvirt.sysinfo_serial='none' for virt driver tests
- XenAPI: Workaround for 6.5 iSCSI bug
- Change warn to debug logs when migration context is missing
- Imported Translations from Zanata
- libvirt: Fix/implement revert-resize for RBD-backed images
- Ensure Glance image 'size' attribute is 0, not 'None'
- Add retry logic for detaching device using LibVirt
- Spread allocations of fixed ips
- Apply scheduler limits to Exact* filters
- Replace eventlet-based raw socket client with requests
- VMware: Handle image size correctly for OVA and streamOptimized images
- XenAPI: Cope with more Cinder backends
- ports & networks gather should validate existance
- Disable IPv6 on bridge devices
- Imported Translations from Zanata
- Imported Translations from Zanata
- Validate translations
- Fix instance not destroyed after successful evacuation
- Imported Translations from Zanata
Comment 6 Lee Yarwood 2016-03-21 11:51:00 EDT
*** Bug 1311634 has been marked as a duplicate of this bug. ***
Comment 7 Prasanth Anbalagan 2016-03-30 12:26:09 EDT
Verified as follows,


Controller
===========

[root@Y-Y-Y-Y~]# yum list installed | grep openstack-nova
openstack-nova-api.noarch        1:12.0.2-4.el7ost       @rhelosp-8.0-puddle    
openstack-nova-cert.noarch       1:12.0.2-4.el7ost       @rhelosp-8.0-puddle    
openstack-nova-common.noarch     1:12.0.2-4.el7ost       @rhelosp-8.0-puddle    
openstack-nova-conductor.noarch  1:12.0.2-4.el7ost       @rhelosp-8.0-puddle    
openstack-nova-console.noarch    1:12.0.2-4.el7ost       @rhelosp-8.0-puddle    
openstack-nova-novncproxy.noarch 1:12.0.2-4.el7ost       @rhelosp-8.0-puddle    
openstack-nova-scheduler.noarch  1:12.0.2-4.el7ost       @rhelosp-8.0-puddle    


Compute
========

[root@X-X-X-X ~]# yum list installed | grep openstack-nova
openstack-nova-common.noarch         1:12.0.2-4.el7ost   @rhelosp-8.0-puddle    
openstack-nova-compute.noarch        1:12.0.2-4.el7ost   @rhelosp-8.0-puddle
Comment 8 errata-xmlrpc 2016-04-07 17:34:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.