Bug 1315395 - Remote execution enable via installer should be done via a migration
Remote execution enable via installer should be done via a migration
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: Stephen Benjamin
Lukas Pramuk
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 10:57 EST by Eric Helms
Modified: 2016-07-27 05:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:04:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14080 None None None 2016-04-22 12:02 EDT
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 08:24:38 EDT

  None (edit)
Description Eric Helms 2016-03-07 10:57:59 EST
The commit https://github.com/Katello/katello-installer/commit/8c27d10955df8557257261c1e3fbc823a45dbadf added smart proxy remote execution enable but gets wiped out on migration.
Comment 1 Eric Helms 2016-03-07 10:58:01 EST
Created from redmine issue http://projects.theforeman.org/issues/14080
Comment 3 Bryan Kearney 2016-03-11 10:10:27 EST
Upstream bug assigned to stbenjam@redhat.com
Comment 4 Bryan Kearney 2016-03-15 16:10:33 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14080 has been closed
-------------
Anonymous
Applied in changeset commit:katello-installer|c67993653f076f792cf420c54a28ec8baff1a5f7.
Comment 7 Lukas Pramuk 2016-07-12 09:19:46 EDT
VERIFIED.

@satellite-6.2.0-19.1.el6sat.noarch
satellite-installer-6.2.0.11-1.el6sat.noarch

>>> I upgraded Satellite 6.1 to 6.2 and checked that REX is on by default

# satellite-installer -S satellite -h | grep remote
    --[no-]enable-foreman-plugin-remote-execution Enable 'foreman_plugin_remote_execution' puppet module (default: true)
    --[no-]enable-foreman-proxy-plugin-remote-execution-ssh Enable 'foreman_proxy_plugin_remote_execution_ssh' puppet module (default: true)
= Module foreman_proxy_plugin_remote_execution_ssh:
    --foreman-proxy-plugin-remote-execution-ssh-enabled  Enables/disables the plugin (default: true)


UI:
foreman_remote_execution 	A plugin bringing remote execution to the Satellite, completing the config management functionality with remote management functionality. 	Foreman Remote Execution team 	0.3.0.11
Comment 9 errata-xmlrpc 2016-07-27 05:04:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.