This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1315399 - Unable to open remote console from services > workloads
Unable to open remote console from services > workloads
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.5.4
Assigned To: Brian McLaughlin
Ramesh A
console
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 11:11 EST by nate stephany
Modified: 2016-05-31 09:41 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.5.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 09:41:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of message (44.52 KB, image/png)
2016-03-07 11:11 EST, nate stephany
no flags Details

  None (edit)
Description nate stephany 2016-03-07 11:11:21 EST
Created attachment 1133832 [details]
screenshot of message

Description of problem:
When attempting to open a remote console to a VMware or RHEV VM from Services > Workloads in UI, console never opens. The message displayed is "noVNC ready: native WebSockets, canvas rendering". The console opens fine if you open it from Infrastructure > Virtual Machines.

Version-Release number of selected component (if applicable):
5.5.2.4

How reproducible:
100%

Steps to Reproduce:
1. Log into CF UI and go to Service > Workloads > any VMW or RHEV VM
2. Click on the remote console icon


Actual results:
Message "noVNC ready: native WebSockets, canvas rendering" displays and nothing ever happens

Expected results:
It should actually open the remote console

Additional info:
Make sure you have accepted certs, opened ports on ESX firewall, etc. and verify that it actually works from Infrastructure > Virtual Machines before testing from Services > Workloads.
Comment 1 Harpreet Kataria 2016-03-07 11:16:44 EST
Brian,

Can you look into this one. Let me know if you have questions.

Thanks,
~Harpreet
Comment 4 Brian McLaughlin 2016-03-16 16:36:44 EDT
Reproduced
Comment 6 CFME Bot 2016-04-14 17:25:46 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=47f5056d2d5d5f067ab6a8b4ed29561413b30c73

commit 47f5056d2d5d5f067ab6a8b4ed29561413b30c73
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Fri Mar 18 11:17:56 2016 -0400
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Fri Mar 18 11:17:56 2016 -0400

    Fix HTML5 consoles from Services > Workloads
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1315399

 app/controllers/vm_or_template_controller.rb | 2 ++
 1 file changed, 2 insertions(+)
Comment 7 CFME Bot 2016-04-14 17:27:21 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a5aadd1ecfbb6718577ec500c1e40c0b869f9e32

commit a5aadd1ecfbb6718577ec500c1e40c0b869f9e32
Merge: 6e0d781 47f5056
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Apr 14 16:49:16 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Apr 14 16:49:16 2016 -0400

    Merge branch 'bz1315399' into '5.5.z'
    
    Fix HTML5 consoles from Services > Workloads
    
    No upstream PR as it was fixed via an updated Gem.  Used current 5.5.z CSP header technique existing in app/controllers/vm_infra_controller.rb:12
    
    Reproduced issue in vCenter 5.5 and RHEV 3.5, verified fix in vCenter 5.5 and RHEV 3.5
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1315399
    
    See merge request !863

 app/controllers/vm_or_template_controller.rb | 2 ++
 1 file changed, 2 insertions(+)
Comment 9 Ramesh A 2016-05-09 04:35:42 EDT
Verified and working fine in 5.5.4.0.20160426160942_629f93b
Comment 11 errata-xmlrpc 2016-05-31 09:41:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1101

Note You need to log in before you can comment on or make changes to this bug.