Bug 1315401 - Importing from Modeshape repo causing issue on server trying to configure repo the first time
Importing from Modeshape repo causing issue on server trying to configure rep...
Status: CLOSED DUPLICATE of bug 1332859
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape, Teiid Designer (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.3.0
Assigned To: Van Halbert
Filip Elias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 11:13 EST by Van Halbert
Modified: 2016-05-04 08:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-04 08:43:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Horia Chiorean 2016-03-07 14:07:16 EST
This is most likely because the new teiid-modeshape modules don't have the correct descriptors: 
- the FS path of the new modules is: org/jboss/teiid/modeshape/sequencer/vdb/main/module.xml
 
while in module.xml the name of the module is "org.teiid.modeshape.sequencer.vdb" (without "jboss").

The correct name for the module(s) should be: org.jboss.teiid.modeshape.sequencer.vdb.

This applies to all the 3 new modules and should be reflected in the CLI scripts as well.
Comment 3 Horia Chiorean 2016-03-08 09:25:46 EST
The other CLI script fix required by this (besides the above) is the name of DDL sequencer which should be: 

"classname="org.teiid.modeshape.sequencer.ddl.TeiidDdlSequencer"

instead of:

"classname="org.teiid.modeshape.sequencer.ddl.DdlSequencer"
Comment 4 Horia Chiorean 2016-04-18 09:50:27 EDT
This (https://bugzilla.redhat.com/show_bug.cgi?id=1315401#c2) has not been fixes in ER2.

Moreover, the VDB and DDL sequencers are now missing altogether from the standalone.xml server configuration. They should be configured during the installation of the teiid-modeshape module.
Comment 5 Thomas Hauser 2016-04-18 16:47:33 EDT
The missing VDB / DDL sequencers have been fixed in the latest installer build (ER2.1). It would be nice if the smokeTests could check for the presence of these elements as well, since the original ER2 build passed all smoke tests.
Comment 6 Van Halbert 2016-05-04 08:43:24 EDT

*** This bug has been marked as a duplicate of bug 1332859 ***

Note You need to log in before you can comment on or make changes to this bug.