Bug 1315408 - Hyphen in LVM name caused wrong filesystem was used to search system files.
Hyphen in LVM name caused wrong filesystem was used to search system files.
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
Unspecified Linux
unspecified Severity unspecified
: GA
: 5.6.0
Assigned To: Hui Song
Satyajit Bulage
smartstate
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 11:28 EST by Hui Song
Modified: 2017-08-31 07:06 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:40:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hui Song 2016-03-07 11:28:49 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Hui Song 2016-03-07 11:33:23 EST
Linux OS will automatically double hyphen, if it exists in the LVM name whenever using as device path. Ex. if vgname = rhel_dhcp181-root, lvname = var, the device path will be /dev/mapper/rhel_dhcp181--root-var. Ignorance this may return empty information in smart state scanning.

https://github.com/ManageIQ/manageiq/issues/7039
Comment 3 Satyajit Bulage 2016-05-03 05:53:20 EDT
Please add verification steps.
Comment 4 Hui Song 2016-05-03 08:25:08 EDT
(In reply to Satyajit Bulage from comment #3)
> Please add verification steps.

1. Create a VM with multiple LVMs.
2. Name LVMs with hyphen inside, such as CFME-root.
3. Install different filesystems in root and other volumes (easier to reproduce the problem).
4. Run SSA to verify the fix.
Comment 5 Satyajit Bulage 2016-05-19 07:57:17 EDT
Created lvm's with given information and Successfully ran SmartState Analysis on the VM. SSA did not return an empty information.

Verified Version :-5.6.0.7-beta2.6.20160516171555_b1be31f
Comment 7 errata-xmlrpc 2016-06-29 11:40:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.