Bug 1315430 - [RFE] As a user I want to be able provision atomic and have it register via subscription manager
[RFE] As a user I want to be able provision atomic and have it register via s...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management (Show other bugs)
6.2.0
Unspecified Unspecified
high Severity high (vote)
: Beta
: --
Assigned To: Partha Aji
Sachin Ghai
http://projects.theforeman.org/issues...
: FutureFeature
Depends On:
Blocks: 1321771
  Show dependency treegraph
 
Reported: 2016-03-07 12:28 EST by Partha Aji
Modified: 2016-07-27 05:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:26:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13843 None None None 2016-04-22 12:03 EDT

  None (edit)
Description Partha Aji 2016-03-07 12:28:49 EST

    
Comment 1 Partha Aji 2016-03-07 12:28:51 EST
Created from redmine issue http://projects.theforeman.org/issues/13843
Comment 2 Partha Aji 2016-03-07 12:28:53 EST
Upstream bug assigned to paji@redhat.com
Comment 4 Bryan Kearney 2016-03-17 16:10:46 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/13843 has been closed
-------------
Partha Aji
Applied in changeset commit:katello|e90aeb652fa62dbe9a8795913cc2d7441918d669.
Comment 5 Sachin Ghai 2016-03-29 06:39:43 EDT
Verified with sat6.2 beta snap5.1

I can provision atomic host and get that register via subscription-manager using 'Katello Atomic kickstart default" template.


and can see correct configuration under redhat.conf.

# cat redhat.conf 
[remote "rhel-atomic-host-ostree"]
url = https://cloud-qe-3.idmqe.lab.eng.bos.redhat.com/pulp/repos/Default_Organization/Dev/cv_ostree/content/dist/rhel/atomic/7/7Server/x86_64/ostree/repo
gpg-verify = false
tls-client-cert-path = /etc/pki/entitlement/1709910426975149119.pem
tls-client-key-path = /etc/pki/entitlement/1709910426975149119-key.pem
tls-ca-path = /etc/rhsm/ca/katello-server-ca.pem
Comment 7 Sachin Ghai 2016-03-30 02:58:01 EDT
I'm getting validation error on manually registering atomic host with sat server.


-bash-4.2# subscription-manager register --activationkey ak_rhel7_atomic --org Default_Organization
Validation failed: Medium Atomic Media does not belong to RedHat 7.2 operating system
Comment 8 Sachin Ghai 2016-04-12 02:24:52 EDT
Verified with sat6.2 beta snap7.1

I can provision atomic host via Satellite and get registered it with satellite by associating Katello Atomic kickstart template.


Also, I can register Atomic host with activation-key:

-bash-4.2# subscription-manager register --org="Default_Organization" --activationkey=ak_atomic
The system has been registered with ID: 26ad685c-1921-4a3a-9f20-8b88a685e136 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Atomic Host
Status:       Subscribed

Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed


I can register it manually

-bash-4.2# subscription-manager register --username admin --password changeme --org="Default_Organization"
Registering to: cloud-qe-3.idmqe.lab.eng.bos.redhat.com:443/rhsm
Environment: Library
The system has been registered with ID: cd4f72a5-0470-449e-8799-2b85fe72d984 


After registering the host witj satellite, I can upgrade atomic with latest ostree from CDN.

-bash-4.2# atomic host upgrade
Updating from: rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard

589 metadata, 2812 content objects fetched; 203173 KiB transferred in 20 seconds
Copying /etc changes: 21 modified, 4 removed, 44 added
Transaction complete; bootconfig swap: yes deployment count change: 1
Changed:
  NetworkManager 1:1.0.6-27.el7 -> 1:1.0.6-29.el7_2
  NetworkManager-libnm 1:1.0.6-27.el7 -> 1:1.0.6-29.el7_2
  atomic 1.6-6.gitca1e384.el7 -> 1.9-4.gitff44c6a.el7
  bind-libs 32:9.9.4-29.el7_2.2 -> 32:9.9.4-29.el7_2.3
  bind-libs-lite 32:9.9.4-29.el7_2.2 -> 32:9.9.4-29.el7_2.3
  bind-license 32:9.9.4-29.el7_2.2 -> 32:9.9.4-29.el7_2.3
  bind-utils 32:9.9.4-29.el7_2.2 -> 32:9.9.4-29.el7_2.3
  ceph-common 1:0.94.3-6.el7cp -> 1:0.94.5-9.el7cp
  cockpit-bridge 0.93-3.el7 -> 0.96-2.el7
  cockpit-docker 0.93-3.el7 -> 0.96-2.el7
  cockpit-ostree 0.93-3.el7 -> 0.96-2.el7
  cockpit-shell 0.93-3.el7 -> 0.96-2.el7
  cronie 1.4.11-14.el7 -> 1.4.11-14.el7_2.1
  cronie-anacron 1.4.11-14.el7 -> 1.4.11-14.el7_2.1
  device-mapper-multipath 0.4.9-85.el7 -> 0.4.9-85.el7_2.1
  device-mapper-multipath-libs 0.4.9-85.el7 -> 0.4.9-85.el7_2.1
  docker 1.8.2-10.el7 -> 1.9.1-25.el7
  docker-selinux 1.8.2-10.el7 -> 1.9.1-25.el7
  etcd 2.2.2-5.el7 -> 2.2.5-1.el7
  initscripts 9.49.30-1.el7 -> 9.49.30-1.el7_2.2
  kernel 3.10.0-327.10.1.el7 -> 3.10.0-327.13.1.el7
  kpartx 0.4.9-85.el7 -> 0.4.9-85.el7_2.1
  krb5-libs 1.13.2-10.el7 -> 1.13.2-12.el7_2
  kubernetes 1.2.0-0.6.alpha1.git8632732.el7 -> 1.2.0-0.9.alpha1.gitb57e8bd.el7
  kubernetes-client 1.2.0-0.6.alpha1.git8632732.el7 -> 1.2.0-0.9.alpha1.gitb57e8bd.el7
  kubernetes-master 1.2.0-0.6.alpha1.git8632732.el7 -> 1.2.0-0.9.alpha1.gitb57e8bd.el7
  kubernetes-node 1.2.0-0.6.alpha1.git8632732.el7 -> 1.2.0-0.9.alpha1.gitb57e8bd.el7
  libblkid 2.23.2-26.el7 -> 2.23.2-26.el7_2.2
  libipa_hbac 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  libmount 2.23.2-26.el7 -> 2.23.2-26.el7_2.2
  librados2 1:0.94.3-6.el7cp -> 1:0.94.5-9.el7cp
  librbd1 1:0.94.3-6.el7cp -> 1:0.94.5-9.el7cp
  libsmbclient 4.2.3-11.el7_2 -> 4.2.3-12.el7_2
  libssh2 1.4.3-10.el7 -> 1.4.3-10.el7_2.1
  libsss_idmap 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  libsss_nss_idmap 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  libuuid 2.23.2-26.el7 -> 2.23.2-26.el7_2.2
  libwbclient 4.2.3-11.el7_2 -> 4.2.3-12.el7_2
  nss-util 3.19.1-4.el7_1 -> 3.19.1-9.el7_2
  openldap 2.4.40-8.el7 -> 2.4.40-9.el7_2
  openssh 6.6.1p1-23.el7_2 -> 6.6.1p1-25.el7_2
  openssh-clients 6.6.1p1-23.el7_2 -> 6.6.1p1-25.el7_2
  openssh-server 6.6.1p1-23.el7_2 -> 6.6.1p1-25.el7_2
  openssl 1:1.0.1e-51.el7_2.2 -> 1:1.0.1e-51.el7_2.4
  openssl-libs 1:1.0.1e-51.el7_2.2 -> 1:1.0.1e-51.el7_2.4
  python-docker-py 1.4.0-118.el7 -> 1.7.2-1.el7
  python-perf 3.10.0-327.10.1.el7 -> 3.10.0-327.13.1.el7
  python-rados 1:0.94.3-6.el7cp -> 1:0.94.5-9.el7cp
  python-rbd 1:0.94.3-6.el7cp -> 1:0.94.5-9.el7cp
  python-sssdconfig 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  quota 1:4.01-11.el7 -> 1:4.01-11.el7_2.1
  quota-nls 1:4.01-11.el7 -> 1:4.01-11.el7_2.1
  samba-client-libs 4.2.3-11.el7_2 -> 4.2.3-12.el7_2
  samba-common 4.2.3-11.el7_2 -> 4.2.3-12.el7_2
  samba-common-libs 4.2.3-11.el7_2 -> 4.2.3-12.el7_2
  samba-common-tools 4.2.3-11.el7_2 -> 4.2.3-12.el7_2
  samba-libs 4.2.3-11.el7_2 -> 4.2.3-12.el7_2
  sssd 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  sssd-ad 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  sssd-client 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  sssd-common 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  sssd-common-pac 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  sssd-ipa 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  sssd-krb5 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  sssd-krb5-common 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  sssd-ldap 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  sssd-proxy 1.13.0-40.el7_2.1 -> 1.13.0-40.el7_2.2
  sudo 1.8.6p7-16.el7 -> 1.8.6p7-17.el7_2
  tuned 2.5.1-4.el7_2.2 -> 2.5.1-4.el7_2.3
  tuned-profiles-atomic 2.5.1-4.el7_2.2 -> 2.5.1-4.el7_2.3
  tzdata 2016a-1.el7 -> 2016b-1.el7
  util-linux 2.23.2-26.el7 -> 2.23.2-26.el7_2.2
Added:
  docker-forward-journald-1.9.1-25.el7.x86_64
  skopeo-1.9-4.gitff44c6a.el7.x86_64
Run "systemctl reboot" to start a reboot
-bash-4.2# atomic host status
  TIMESTAMP (UTC)         VERSION     ID             OSNAME               REFSPEC                                                        
  2016-03-29 20:52:18     7.2.3       d620e84186     rhel-atomic-host     rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard     
* 2016-02-18 15:34:28     7.2.2-1     04019d7e50     rhel-atomic-host     rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard     
-bash-4.2#
Comment 10 errata-xmlrpc 2016-07-27 05:26:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.