Bug 1315445 - Use package manager dnf on fedora 24
Use package manager dnf on fedora 24
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 13:31 EST by Lukas Slebodnik
Modified: 2016-03-09 05:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 05:03:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for mock upstream (4.74 KB, application/mbox)
2016-03-07 13:31 EST, Lukas Slebodnik
no flags Details

  None (edit)
Description Lukas Slebodnik 2016-03-07 13:31:33 EST
Created attachment 1133889 [details]
Patch for mock upstream

Description of problem:
    The package manager dnf was used on fedora rawhide.
    Then fedora 24 was branched from rawhide but package
    manager was changed from dnf to default yum-deprecated.

Version-Release number of selected component (if applicable):
mock-1.2.15-1.fc24.noarch
Comment 1 Miroslav Suchý 2016-03-09 05:03:20 EST
I'm trying to be on-pair with Koji. Originally I hopped that dnf will be used for F23, then F24, but no luck. Rel-engs are still using yum.
So it does not make sense to build F24 packages in Copr using DNF and in Koji using YUM.

The rawhide is little different since I'm trying to catch there rel-engs bugs related to DNF before it hit Koji. So rel-eng team can be sure that the deployment in Koji will be problemless.

Note You need to log in before you can comment on or make changes to this bug.