Bug 1315448 - upgrade from cfme-5.5.0 to 5.5.2 causes ntp_update cronjob to fail
upgrade from cfme-5.5.0 to 5.5.2 causes ntp_update cronjob to fail
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: GA
: 5.6.0
Assigned To: Satoe Imaishi
Matouš Mojžíš
upgrade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 14:10 EST by Colin Arnott
Modified: 2016-11-07 23:00 EST (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:40:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Arnott 2016-03-07 14:10:25 EST
Description of problem:
after an upgrade from cfme-5.5.0 to cfme-5.5.2, an ntp_update cronjob fails and writes errors to /var/spool/mail/root

this appears to be caused by the removal of the folder /var/www/miq/lib/util/ntp as it no longer exists on 5.5.2, but does exist on 5.5.0

Version-Release number of selected component (if applicable):
cfme-5.5.2.4-1.el7cf.x86_64

How reproducible:
very

Steps to Reproduce:
1. setup new cfme-5.5.0 appliance
2. register the system with RHSM through the webGUI
2. upgrade to cfme-5.5.2

Actual results:
lots of errors in /var/spool/mail/root:

Expected results:
successful upgrade, no cron errors
Comment 3 Colin Arnott 2016-03-07 15:13:04 EST
If you remove the following two lines from root's crontab it will resolve this issue perminantly:

*/15 * * * * /var/www/miq/lib/util/ntp/run_ntpdate
@reboot /var/www/miq/lib/util/ntp/run_ntpdate
Comment 5 Joe Rafaniello 2016-03-08 11:58:51 EST
Nick, can you investigate?  Is this already fixed?
Comment 6 Nick Carboni 2016-03-08 13:08:59 EST
Ah I think when we removed this here (https://github.com/ManageIQ/manageiq/pull/5705) we didn't account for existing entries in the crontab files.

We could doc that when upgrading these need to be removed.
Any other ideas Joe?
Comment 7 Nick Carboni 2016-03-08 13:39:43 EST
Also `crontab -l | grep -v "run_ntpdate" | crontab` should do the job

We will look into getting this into the upgrade spec file.
Comment 9 Matouš Mojžíš 2016-05-20 09:18:17 EDT
So, I verified and relationships are really unified in both services and clouds, but this BZ describes, that everything should be unified, so I don't know whether to make it verified or wait until all will be unified...
Comment 10 Matouš Mojžíš 2016-05-23 07:47:27 EDT
Sorry, wrong BZ.
Comment 11 Matouš Mojžíš 2016-05-23 14:09:04 EDT
Verified in:5.6.0.7-beta2.6.20160516171555_b1be31f 
I updated 5.5.0 to 5.6.0.7 and there is no entry in crontab for running script, that is missing.(There is no entry at all.)
Comment 13 errata-xmlrpc 2016-06-29 11:40:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.