Bug 1315459 - Remove Plugin dependency on ActionDispatch::Static middleware
Remove Plugin dependency on ActionDispatch::Static middleware
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Red Hat Access (Show other bugs)
5.6.0
Unspecified Unspecified
unspecified Severity urgent
: GA
: 5.6.0
Assigned To: Lindani Phiri
Satyajit Bulage
access:plugin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 14:36 EST by Lindani Phiri
Modified: 2016-07-27 02:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0 (rubygem-redhat_access_cfme-1.0.1-1)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:40:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 14:50:04 EDT

  None (edit)
Description Lindani Phiri 2016-03-07 14:36:23 EST
Modify plugin so that it does not depend on ActionDipatch:Static middleware.
Due to configuration changes in Core, this will no longer work as per email below:


Hi Lindani,

Satoe is in the process of building nightly builds for downstream in preparation for the upcoming CloudForms 4.1 release.  During her investigations, she found that the redhat_access_cfme gem is blowing up during application initialization with

    No such middleware to insert before: ActionDispatch::Static

Note that we have changed the configuration to no longer server static assets from Rails (i.e. config.server_static_assets = false), so the check that the gem is doing to find the ActionDispatch::Static middleware may no longer be valid.  I'm not sure if you were piggybacking that middleware because it was in a convenient spot in the Rack stack, or if you actually needed to come before that specific one because you were relying on assets being served statically.

For now, Satoe has commented out installing the rpm in order to get a build working, and we now have one that you could use for debugging the problem.

Thanks,
Jason
Comment 3 Satyajit Bulage 2016-04-21 06:48:43 EDT
Please add verification steps
Comment 4 Lindani Phiri 2016-04-21 09:35:43 EDT
Verify that the CFME appliance starts correctly and that the "Red Hat Insights" UI screens render correctly without any HTTP 404 errors when fetching any required images/fonts files from the server.
Comment 5 Satyajit Bulage 2016-04-25 02:54:23 EDT
Verified the CFME appliance starts correctly and that the "Red Hat Insights" UI screens render correctly without any HTTP 404 errors when fetching any required images/fonts files from the server.

Verified Version :- 5.6.0.4-beta2.3.20160421172650_719e256
Comment 8 errata-xmlrpc 2016-06-29 11:40:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.