Bug 1315460 - Make thin_ls available in Fedora 23+
Make thin_ls available in Fedora 23+
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: device-mapper-persistent-data (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 14:37 EST by Andy Goldstein
Modified: 2016-03-12 06:49 EST (History)
10 users (show)

See Also:
Fixed In Version: device-mapper-persistent-data-0.6.2-0.1.rc6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1315452
Environment:
Last Closed: 2016-03-12 06:49:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Goldstein 2016-03-07 14:37:33 EST
+++ This bug was initially created as a clone of Bug #1315452 +++

Description of problem:

Openshift people are looking for availability of thin_ls on rhel. This is
useful to figure out COW layer usage of container. Update device-mapper-persistent-data package to latest for 7.3.

Version-Release number of selected component (if applicable):



How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vivek Goyal on 2016-03-07 14:20:33 EST ---

Here is upstream discussion looking for thin_ls.

https://github.com/google/cadvisor/issues/959#issuecomment-191326562

--- Additional comment from Andy Goldstein on 2016-03-07 14:26:52 EST ---

This is needed for both Kubernetes and OpenShift. thin_ls gives us the ability to determine the amount of storage that a container has used in its COW layer.

--- Additional comment from RHEL Product and Program Management on 2016-03-07 14:35:49 EST ---

Since this bug report was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 1 Andy Goldstein 2016-03-07 14:38:10 EST
This is the same request as the cloned bz, except for Fedora.
Comment 2 Fedora Update System 2016-03-08 04:18:22 EST
device-mapper-persistent-data-0.6.2-0.1.rc5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-305e202b16
Comment 3 Fedora Update System 2016-03-09 17:56:42 EST
device-mapper-persistent-data-0.6.2-0.1.rc6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-305e202b16
Comment 4 Fedora Update System 2016-03-12 06:49:40 EST
device-mapper-persistent-data-0.6.2-0.1.rc6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.