Bug 1315470 - Canceling out of fusor-installer restarts network, named, and dhcpd
Canceling out of fusor-installer restarts network, named, and dhcpd
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-installer (Show other bugs)
1.0
All Linux
unspecified Severity low
: ga
: 1.0
Assigned To: Jesus M. Rodriguez
Tasos Papaioannou
: Triaged
Depends On:
Blocks: rhci-sprint-14
  Show dependency treegraph
 
Reported: 2016-03-07 15:16 EST by Tasos Papaioannou
Modified: 2016-09-13 12:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:27:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tasos Papaioannou 2016-03-07 15:16:44 EST
Description of problem:

If I use ctrl-C or select "20. Cancel installation" to exit out of fusor-installer, I get the following output:

****
Modify settings as needed, and then proceed with the installation:
1.      Proceed with the values shown
2.           Network interface | eth1
[...]
18. Do not configure networking
19. Do not configure firewall
20. Cancel installation
20
  The full log is at /var/log/katello-installer/katello-installer.log
Restarting network...
Restarting named...
Restarting dhcpd...
Job for dhcpd.service failed because the control process exited with error code. See "systemctl status dhcpd.service" and "journalctl -xe" for details.
****

Version-Release number of selected component (if applicable):

QCI-1.0-RHEL-7-20160302.t.0

How reproducible:

100%

Steps to Reproduce:
1.) Cancel out of initial run of fusor-installer.
2.) See above output.

Actual results:

Canceling out of fusor-installer restarts network, named, and dhcpd.

Expected results:

No service restarts if canceling out of fusor-installer.

Additional info:
Comment 1 John Matthews 2016-03-07 15:24:22 EST
Likely related to launch-fusor-installer, it is a wrapper that calls fusor-installer from the ISO install then it restarts some system services.

We can check the exit status of fusor-installer prior to initiating the restart of the services.
Comment 2 Jesus M. Rodriguez 2016-03-29 10:29:26 EDT
The fusor-installer was remapping the cancellation exit code from 100 to 0. This prevented the launch script from knowing the process was canceled. The fix was to simply let the cancellation exit code return as is with no remapping.

This fix works for entering 20 at the menu, as well as CTRL-C at the menu.

https://github.com/fusor/fusor-installer/pull/54
Comment 3 Tasos Papaioannou 2016-06-22 11:25:25 EDT
Verified on QCI-1.2-RHEL-7-20160621.t.0.
Comment 9 errata-xmlrpc 2016-09-13 12:27:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.