This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1315492 - Using vagrant-libvirt locks up machine on "Waiting for domain to get IP"
Using vagrant-libvirt locks up machine on "Waiting for domain to get IP"
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 16:57 EST by Luis Pabón
Modified: 2016-11-08 17:25 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 07:20:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Pabón 2016-03-07 16:57:14 EST
Description of problem:
Using the new kernel-4.4.3-300.fc23.x86_64 locks up vagrant-libvirt with "Waiting for domain to get IP".  Not only that, but after a while, the entire system is locked.

Reverted to kernel-4.2.6-301 (just happend to be the older version I had at the moment), and it works.

Version-Release number of selected component (if applicable):


How reproducible:
Very.  Tried it on three separate systems.  A Laptop (lenovo), desktop, and server-class machine.


Steps to Reproduce:
Use the following vagrant

https://github.com/lpabon/aplo-poc or https://github.com/heketi/vagrant-heketi

1. sudo dnf -y install libvirt vagrant-libvirt qemu-kvm vagrant ansible git
2. service libvirtd start
3. sudo vagrant up --no-provision --provider=libvirt

Actual results:
Vagrant setup does not finish.  After a while, system becomes unusable.

Expected results:
Vagrant setup should finish
Enter the master system using: sudo vagrant ssh master 

Additional info:
Comment 1 Luis Pabón 2016-03-07 17:01:15 EST
Confirmed that it works also with kernel-4.3.5-300
Comment 2 Laura Abbott 2016-03-07 17:18:55 EST
I'm not seeing that behavior using https://github.com/heketi/vagrant-heketi and the instructions you gave. The command sudo vagrant up --no-provision --provider=libvirt completes just fine for me and afterwards I see

$ sudo vagrant status
Current machine states:

client                    running (libvirt)
storage0                  running (libvirt)
storage1                  running (libvirt)
storage2                  running (libvirt)
storage3                  running (libvirt)

This is on my machine with 4.4.3-300.fc23.x86_64. Can you grab the system logs and share what version of userspace packages you have?
Comment 3 Luis Pabón 2016-03-08 07:20:47 EST
Hmm, I just tried it again on 4.3.5 and it blocked on "Waiting for domain to get an IP address..." So it is not the kernel. I'll close until I get more information, and I will probably have to place a bug on vagrant-libvirt instead.

Thanks for the help!

Note You need to log in before you can comment on or make changes to this bug.