Bug 1315503 - NewPkg: Add python-elasticsearch
NewPkg: Add python-elasticsearch
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Luke Meyer
Junqi Zhao
:
Depends On:
Blocks: 1315504
  Show dependency treegraph
 
Reported: 2016-03-07 18:06 EST by Rich Megginson
Modified: 2016-11-22 11:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-22 11:12:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2016-03-07 18:06:59 EST
Description of problem:
Upstream has a new component - curator: https://github.com/openshift/origin-aggregated-logging#curator

This component needs the python-elasticsearch version 2.3.0 package.  Fedora already has 2.0.0 - https://bugzilla.redhat.com/show_bug.cgi?id=1271416

Version-Release number of selected component (if applicable):
2.3.0 - we need 2.3.0 because it has support for client cert/key auth.

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
This package will only be used in the curator image/container.
Comment 1 Rich Megginson 2016-04-05 19:00:14 EDT
Thanks to tdawson I am able to build and install python-elasticsearch and elastic-curator using mock with rhaos-3.2-rhel-7-candidate.
Comment 2 Luke Meyer 2016-06-02 06:11:27 EDT
So can this bug be closed or do we need it to track something?
Comment 3 Rich Megginson 2016-06-02 12:14:57 EDT
(In reply to Luke Meyer from comment #2)
> So can this bug be closed or do we need it to track something?

I don't know.  I think QE has to verify that the package can be installed from the official RH AOS 3.2.x channel.
Comment 5 Troy Dawson 2016-11-08 17:24:53 EST
This packages is available in the official openshift enterprise / openshift container platform 3.2 and 3.3 channels.  Marking it on qe so it can be tested.
Will mark it as Closed / Current Release if it passes QE
Comment 6 Xia Zhao 2016-11-21 04:53:18 EST
@juzhao Could you please update status here for this issue? Do you still have issue on deleting indices for 3.2.0 level logging stacks?
Comment 7 Junqi Zhao 2016-11-22 04:53:54 EST
@xiazhao, Tested on OCP 3.3.1 + Logging 3.3.1,
python-elasticsearch version is 2.3.0, all the three cases passed testing

https://tcms.engineering.redhat.com/case/509062/?from_plan=14587
https://tcms.engineering.redhat.com/case/536618/?from_plan=14587
https://tcms.engineering.redhat.com/case/531500/?from_plan=14587

But when tested on OCP 3.3.1 + Logging 3.2.1, it seems curator could not process more than one project with same time and time unit. Will confirm this issue tomorrow.
Comment 8 Xia Zhao 2016-11-22 05:30:57 EST
Verified with 3.2.1 images on ops registry, curator worked fine on process more than one project with same time and time unit, set to verified:

openshift3/logging-elasticsearch    15fb42270514
openshift3/logging-kibana    b420c7b0f4e6
openshift3/logging-curator    2c60445c0b6e
openshift3/logging-fluentd    77a64b668f70
openshift3/logging-deployment    d7efd0e669f7

Note You need to log in before you can comment on or make changes to this bug.