Bug 1315611 - version bump on fedrora 23
version bump on fedrora 23
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: iproute (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Phil Sutter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 03:48 EST by Tobias Jungel
Modified: 2016-05-24 03:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 07:35:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobias Jungel 2016-03-08 03:48:06 EST
is there a reason not to have iproute 4.4.0 for Fedora 23? Currently 4.4.0 is only built for 24+
Comment 1 Phil Sutter 2016-03-08 07:35:18 EST
Hi Tobias,

(In reply to Tobias Jungel from comment #0)
> is there a reason not to have iproute 4.4.0 for Fedora 23? Currently 4.4.0
> is only built for 24+

AFAICT, Fedora 23 is in maintenance phase. So unless there is good reason, I would not want to update the base version. In case you discovered a defect in Fedora 23's iproute-4.1.1, please open an appropriate ticket and I'll backport what is necessary to get it fixed.

HTH, Phil
Comment 2 Tobias Jungel 2016-03-13 09:43:46 EDT
I sort of expected something like that. Having said that its not really satisfying, since new kernel features get in but not the respective iproute release addressing them.
Comment 3 Phil Sutter 2016-03-14 07:15:38 EDT
Hi Tobias,

(In reply to Tobias Jungel from comment #2)
> I sort of expected something like that. Having said that its not really
> satisfying, since new kernel features get in but not the respective iproute
> release addressing them.

OK, that is indeed lame. I wasn't aware stable Fedora versions (even F22) receive full kernel updates. Looks like I have to reconsider my maintenance policy.

Thanks, Phil
Comment 4 Tobias Jungel 2016-03-14 16:46:34 EDT
Sounds great.

Thanks, Tobi
Comment 5 Phil Sutter 2016-03-14 17:34:15 EDT
Hi,

(In reply to Tobias Jungel from comment #4)
> Sounds great.
> 
> Thanks, Tobi

I had an internal discussion about the topic and found out that kernel version updates in stable releases are rather a necessary evil than means to provide new features. Therefore they don't serve as argument to apply the same practice to the iproute package, as well.

That being said, it seems not to be an issue to backport features which don't harm the remaining package's stability. So if you desperately need support for something in iproute, open a ticket and I will check if a backport is both feasible and non-intrusive to be regarded as safe enough to go into a stable release.

Cheers, Phil (who starts to fear an upcoming sh*tload of feature requests ;)
Comment 6 Tobias Jungel 2016-05-24 03:07:37 EDT
Since it was working fine so far internally I made a copr project for the 4.4 version of iproute: toanju/iproute2

cheers
Tobi (who hopes, that there weren't too many sleepless nights ;)

Note You need to log in before you can comment on or make changes to this bug.