Bug 1315623 - SELinux is preventing gnome-shell from using the 'signull' accesses on a process.
SELinux is preventing gnome-shell from using the 'signull' accesses on a proc...
Status: CLOSED DUPLICATE of bug 1314433
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0c8f99db189740acdc7f54555c4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 04:16 EST by Vít Ondruch
Modified: 2016-03-09 07:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 07:15:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2016-03-08 04:16:10 EST
Description of problem:
SELinux is preventing gnome-shell from using the 'signull' accesses on a process.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gnome-shell should be allowed signull access on processes labeled unconfined_dbusd_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gnome-shell /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:unconfined_dbusd_t:s0-s0
                              :c0.c1023
Target Objects                Unknown [ process ]
Source                        gnome-shell
Source Path                   gnome-shell
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-176.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.4.0-1.fc24.x86_64 #1 SMP Mon Jan
                              11 16:48:24 UTC 2016 x86_64 x86_64
Alert Count                   2
First Seen                    2016-03-08 10:14:42 CET
Last Seen                     2016-03-08 10:14:42 CET
Local ID                      f638b1a1-340e-4585-971e-603332b7ec90

Raw Audit Messages
type=AVC msg=audit(1457428482.581:277): avc:  denied  { signull } for  pid=1541 comm="ibus-daemon" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_dbusd_t:s0-s0:c0.c1023 tclass=process permissive=0


Hash: gnome-shell,xdm_t,unconfined_dbusd_t,process,signull

Version-Release number of selected component:
selinux-policy-3.13.1-176.fc25.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.4.0-1.fc24.x86_64
type:           libreport

Potential duplicate: bug 1314433
Comment 1 Lukas Vrabec 2016-03-09 07:15:03 EST

*** This bug has been marked as a duplicate of bug 1314433 ***

Note You need to log in before you can comment on or make changes to this bug.