Bug 1315629 - /usr/share/selinux/devel/include/roles/unconfineduser.if: Syntax error
/usr/share/selinux/devel/include/roles/unconfineduser.if: Syntax error
Status: CLOSED DUPLICATE of bug 1319338
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
24
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Petr Lautrbach
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 04:42 EST by Ralf Corsepius
Modified: 2016-04-08 14:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-08 14:51:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2016-03-08 04:42:06 EST
Description of problem:

On f24:

# dnf update
...
  Upgrading   : selinux-policy-devel-3.13.1-176.fc24.noarch            77/422 
/usr/share/selinux/devel/include/roles/unconfineduser.if: Syntax error on line 706 unconfined_t [type=IDENTIFIER]
/usr/share/selinux/devel/include/contrib/docker.if: Syntax error on line 503 docker_t [type=IDENTIFIER]
...


# dnf reinstall selinux-policy-devel
...
Reinstalling: selinux-policy-devel-3.13.1-176.fc24.noarch                                                           1/2 
/usr/share/selinux/devel/include/roles/unconfineduser.if: Syntax error on line 706 unconfined_t [type=IDENTIFIER]
/usr/share/selinux/devel/include/contrib/docker.if: Syntax error on line 503 docker_t [type=IDENTIFIER]
Comment 1 Richard W.M. Jones 2016-03-21 07:38:07 EDT
Same thing observed with selinux-policy-devel-3.13.1-179.fc25.noarch
Comment 2 Ben Cardoen 2016-04-02 02:03:10 EDT
I have the same problem, with
selinux-policy-devel-3.13.1-180.fc25.noarch
Comment 3 Miroslav Grepl 2016-04-04 04:27:55 EDT
This is known issue. See

https://github.com/fedora-selinux/selinux/pull/21
Comment 4 Petr Lautrbach 2016-04-08 14:51:43 EDT

*** This bug has been marked as a duplicate of bug 1319338 ***

Note You need to log in before you can comment on or make changes to this bug.