Bug 1315635 - [RFE] skyring-setup.sh should be removed from rhscon-core
[RFE] skyring-setup.sh should be removed from rhscon-core
Status: CLOSED NOTABUG
Product: Red Hat Storage Console
Classification: Red Hat
Component: core (Show other bugs)
2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2
Assigned To: Nishanth Thomas
sds-qe-bugs
Anjana Suparna Sriram
: Reopened, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 04:49 EST by Martin Kudlej
Modified: 2016-05-24 01:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-24 01:46:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2016-03-08 04:49:49 EST
Description of problem:
I think skyring-setup.sh should be transformed into documentation: 

$ cat skyring-setup.sh

...

- this should be completely removed, see bug 1298096
   info "Disabling firewalld"
   systemctl stop firewalld && systemctl disable firewalld

- this should be part of documentation
    info "Starting services"
    # Enable and start the salt-master:
    systemctl enable salt-master
    systemctl start salt-master

    # Enable and start MongoDB
    systemctl enable mongod
    systemctl start mongod

...

    info "Creating skyring database"
    # Configuring MongoDB

    mongo <<EOF
    use skyring
    db.leads.findOne()
    show collections
    db.createUser( { "user" : "admin", "pwd": "admin", "roles" : ["readWrite", "dbAdmin", "userAdmin"] })
    show users
    EOF
    
    # Start the skyring server
    systemctl enable skyringd
    systemctl start skyringd

    info "Setup graphite user"
    /usr/lib/python2.7/site-packages/graphite/manage.py syncdb --noinput

    chown apache:apache /var/lib/graphite-web/graphite.db
# service and chkconfig should be chnaged to systemctl
    service carbon-cache start && chkconfig carbon-cache on
    service httpd start && chkconfig httpd on

...


Version-Release number of selected component (if applicable):
rhscon-core-0.0.8-10.el7.x86_64
rhscon-ui-0.0.19-1.el7.noarch
rhscon-ceph-0.0.6-10.el7.x86_64

How reproducible:
100%
Comment 2 Nishanth Thomas 2016-03-10 05:15:50 EST
Why do you think so? So you expect all these things will be done manually?
What is the problem in providing a script like this to ease the post installation tasks?
Comment 3 Martin Kudlej 2016-03-10 05:49:35 EST
I think "systemctl" commands should be in documentation as they are for example here https://access.redhat.com/documentation/en/red-hat-ceph-storage/version-1.3/red-hat-ceph-storage-13-installation-guide-for-rhel-x86-64/

Then there are commands for set up internal accounts, for example DB accounts. I think this should be in documentation because admin who installs USM, should be able to set up his own accounts or this. It is not safe to have default accounts in applications.
Comment 4 Nishanth Thomas 2016-03-10 06:06:09 EST
I agree that "systemctl" commands should be in the documentation. But is it a good idea leave all the post installation tasks to the administrator and he does a bunch things manually to make the USM to work? I don't think so.
Comment 5 Martin Kudlej 2016-03-11 05:10:02 EST
We've agreed on systemctl commands.

This can be in setup script but user should be to set password for admin(script parameter for example).
    mongo <<EOF
    use skyring
    db.leads.findOne()
    show collections
    db.createUser( { "user" : "admin", "pwd": "admin", "roles" : ["readWrite", "dbAdmin", "userAdmin"] })
    show users
    EOF

I think this can be also in setup script.    
    info "Setup graphite user"
    /usr/lib/python2.7/site-packages/graphite/manage.py syncdb --noinput
    chown apache:apache /var/lib/graphite-web/graphite.db

If you see there left just few lines in setup script so I think they can be in documentation too.
Comment 6 RHEL Product and Program Management 2016-03-22 06:15:53 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.