Bug 1315659 - [Tier]: Following volume restart, tierd shows failure at status on some nodes
[Tier]: Following volume restart, tierd shows failure at status on some nodes
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
tier-glusterd
: ZStream
Depends On: 1288051
Blocks: 1276245 1318498
  Show dependency treegraph
 
Reported: 2016-03-08 06:22 EST by hari gowtham
Modified: 2016-06-16 09:59 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1288051
: 1318498 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:59:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-08 06:24:46 EST
REVIEW: http://review.gluster.org/13646 (TIER: stopping the tierd when the volume goes down) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2016-03-08 14:21:01 EST
REVIEW: http://review.gluster.org/13646 (TIER: stopping the tierd when the volume goes down) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2016-03-08 14:39:27 EST
REVIEW: http://review.gluster.org/13646 (TIER: stopping the tierd when the volume goes down) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Vijay Bellur 2016-03-14 00:51:03 EDT
REVIEW: http://review.gluster.org/13646 (TIER: stopping the tierd when the volume goes down) posted (#4) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 5 Vijay Bellur 2016-03-15 02:06:06 EDT
COMMIT: http://review.gluster.org/13646 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 4d37476f264bdb7e213f302840ac3238dc6d9791
Author: hari gowtham <hgowtham@redhat.com>
Date:   Tue Mar 8 16:38:34 2016 +0530

    TIER: stopping the tierd when the volume goes down
    
    If there are large number of files to be migrated
    and by this time if the volume goes down, then the tierd
    has to be stopped. But on a huge query file list it keeps
    checking for each file before stopping. If the volume comes
    up before the old tierd dies then due to the
    presence of old tierd new one won't be created. After
    the old one completes the task, it dies and the status
    ends up as failed.
    
    This patch will check if the status is still running and then let
    it continue its work. Else it will stop running the tierd.
    
    Change-Id: I6522a4e2919e84bf502b99b13873795b9274f3cd
    BUG: 1315659
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/13646
    Tested-by: Dan Lambright <dlambrig@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 6 Niels de Vos 2016-06-16 09:59:45 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.