Bug 1315663 - qemu:///session disconnects after 30 seconds
qemu:///session disconnects after 30 seconds
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 06:40 EST by Keit
Modified: 2016-04-01 13:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 11:13:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Displaying error (36.71 KB, image/png)
2016-03-08 06:40 EST, Keit
no flags Details
Running qemu///session (57.89 KB, image/png)
2016-03-08 06:41 EST, Keit
no flags Details
Disconnected session (39.49 KB, image/png)
2016-03-08 06:42 EST, Keit
no flags Details

  None (edit)
Description Keit 2016-03-08 06:40:19 EST
Created attachment 1134104 [details]
Displaying error

Description of problem:
After 30 seconds of connecting to a User Session, if no VM is started, the connection is dropped.

This has worked previously.

Version-Release number of selected component (if applicable):

Archlinux updated a few minutes ago.

[xxx@xxxx]$ sudo pacman -Q libvirt virt-manager
libvirt 1.3.2-2
virt-manager 1.3.2-2


How reproducible:


Steps to Reproduce:
1. Connect to User Session (qemu:///session)
2. Wait 30 seconds, without starting any VM
3.

Actual results:
Connection is dropped and a new connect action is needed.

Expected results:
Connection stays up. Necessary if additional VM configuration is needed.

Additional info:

Error
===========================
Error polling connection 'qemu:///session': internal error: client socket is closed

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 385, in _handle_tick_queue
    conn.tick_from_engine(**kwargs)
  File "/usr/share/virt-manager/virtManager/connection.py", line 1319, in tick_from_engine
    raise e  # pylint: disable=raising-bad-type
libvirtError: internal error: client socket is closed
===========================

Error mentioned on Arch foruns:
https://bbs.archlinux.org/viewtopic.php?id=209766

Doesn't seems to be related in my case because I'm not using the 'qemu///system', so libvirt service is not needed to be enabled on systemd.
https://bugzilla.redhat.com/show_bug.cgi?id=1314881

Screenshots showing the error.
Comment 1 Keit 2016-03-08 06:41 EST
Created attachment 1134105 [details]
Running qemu///session
Comment 2 Keit 2016-03-08 06:42 EST
Created attachment 1134106 [details]
Disconnected session
Comment 3 Cole Robinson 2016-03-09 10:09:22 EST
there's this fedora bug too:

https://bugzilla.redhat.com/show_bug.cgi?id=1315606

seems a libvirt regression
Comment 4 Cole Robinson 2016-03-10 16:15:58 EST
Martin posted the patch upstream:

https://www.redhat.com/archives/libvir-list/2016-March/msg00339.html
Comment 5 Cole Robinson 2016-03-23 11:13:24 EDT
Patch was applied
Comment 6 Keit 2016-03-28 06:50:47 EDT
Issue still ongoing.

This patch is still not available on https://libvirt.org/sources/libvirt-1.3.2.tar.gz.

Is it possible to apply the patch on any of this files?

https://www.archlinux.org/packages/community/x86_64/libvirt/files/

Versions on my system, at the moment:

virt-manager 1.3.2-4
libvirt 1.3.2-3
libvirt-glib 0.2.3-1
libvirt-python 1.3.1-1
virtviewer 3.0-1
Comment 7 Cole Robinson 2016-04-01 13:52:04 EDT
The patch isn't in a released libvirt version yet, it will be in libvirt 1.3.3. If you want the patch in arch, you'll need to contact the arch maintainers and ask them to backport this patch:

commit 6541a2b4acd453ebbf10a4427f9ec4e794d3ba6d
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Tue Mar 1 15:42:32 2016 +0100

    daemon: Properly check for clients

Note You need to log in before you can comment on or make changes to this bug.