Bug 1315669 - Fix for compile under EL6
Fix for compile under EL6
Status: NEW
Product: Fedora EPEL
Classification: Fedora
Component: keepassx (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Bailey
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 06:56 EST by Frank Büttner
Modified: 2016-03-08 12:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch needed for compiling. (408 bytes, patch)
2016-03-08 06:56 EST, Frank Büttner
no flags Details | Diff

  None (edit)
Description Frank Büttner 2016-03-08 06:56:19 EST
Created attachment 1134110 [details]
The patch needed for compiling.

The last Version(keepassx-2.0.2) of it can be build under EL6 with one patch and some fixed on the spec file.

Spec file:
Patch0:         keepassx-rhel6.patch

%if 0%{?rhel} == 6
BuildRequires:  qt4-devel >= 4.6
%endif

%prep
%setup -q
%if 0%{?rhel} == 6
%patch0 -p1
%endif


%install
%make_install
%find_lang %{name} --with-qt

%if 0%{?rhel} == 6
rm -f %{buildroot}%{_datadir}/%{name}/translations/keepassx_en_plurals.qm
%endif
Comment 1 Greg Bailey 2016-03-08 12:27:22 EST
I'd be hesitant to incorporate this patch as the upgrade from keepassx from 0.4 to 2.0 on other OS versions caused a fair amount of backlash as that upgrade apparently introduced interoperability problems for some users.

Note You need to log in before you can comment on or make changes to this bug.