Bug 131567 - get rid of brackets quoting canna status strings
get rid of brackets quoting canna status strings
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Canna (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-02 08:11 EDT by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 06:01:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2004-09-02 08:11:09 EDT
Description of problem:
Canna has status strings, like "[ あ ]" and "[漢字]",
but the brackets seems superfluous and take up excessive
space in gimlet's status display for example.
So I would like to suggest that they be removed by cannaLE
at least.

How reproducible:
Run iiimf in ja.

Steps to Reproduce:
1. Turn on iiimf.
2. Enter some text and press Space.
3. Press Space again.
  
Actual results:
1. [ あ ]
2. [漢字]
3. [一覧]

Expected results:
1.  あ 
2. 漢字
3. 一覧
Comment 1 Nakai 2004-09-02 13:42:27 EDT
The braces and mode text are what users decide
in /usr/share/canna/*.canna. So we should not remove
braces in CannaLE.

See
fgrep set-mode-display /usr/share/canna/*.canna
Comment 2 Akira TAGOH 2004-09-03 03:39:27 EDT
Jens, I agree with you. the status string should be unified and
apparently those broke it.  Although canna uses the hardcoded status
string by default, canna has the facility to change it. IMHO any
applications which depends on canna should be allowed to change those.
Comment 3 Akira TAGOH 2004-09-03 04:11:04 EDT
Comment #1:
Unfortunately no. for our default, canna is going to read
/etc/canna/default.canna, and set-mode-display won't be called unless
they modify it or add it into .canna. however Canna LE can't read
.canna you know, because of #125331. so right now people won't be able
to change the status string.  Since it's configuratable, I don't think
the applications shouldn't change the status string. and I don't also
think it ignores the user prefs -- accordingly although Canna LE
ignores it for now, it will be fixed in the future. and it's a
separated bug.
Comment 4 Jens Petersen 2004-09-29 10:02:04 EDT
Basically the suggestion I'm making is just to change the
Canna default status strings to omit the [ and ].
Comment 5 Akira TAGOH 2005-09-26 06:01:48 EDT
After some times went by, I consider cloging this due to some reasons:
 - Canna doesn't evaluate the configuration with KC_SETINIFILENAME expectedly. I
mean it doesn't allow to just override some items only. that way isn't flexible.
 - even if we expected to change this in the system-wide configuration, people
could revert it in their user configuration easily. this means we can't ensure
this change and can't rely on that.
 - providing the state as the icon say looks better than using the text from Canna.
 - upstream is less activity.
 - This isn't an important issue.
 - Canna is now moved into Extras.
 - I wonder if I have a time to fix this

Note You need to log in before you can comment on or make changes to this bug.