Bug 131569 - __might_sleep() bug on removal of device in bridge.
Summary: __might_sleep() bug on removal of device in bridge.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-02 12:47 UTC by David Woodhouse
Modified: 2015-01-04 22:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 10:02:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 2004-09-02 12:47:51 UTC
2.6.8-1.521 i686 UP

Debug: sleeping function called from invalid context at
include/asm/semaphore.h:119
in_atomic():1[expected: 0], irqs_disabled():0
 [<0211b765>] __might_sleep+0x82/0x8c
 [<021a5eea>] sysfs_hash_and_remove+0x1c/0x1ce
 [<129a4f32>] br_sysfs_removeif+0x18/0x20 [bridge]
 [<129a1908>] br_del_if+0x23/0x10b [bridge]
 [<129a2b27>] br_device_event+0x11f/0x17c [bridge]
 [<0212ccf5>] notifier_call_chain+0x17/0x30
 [<022a0550>] unregister_netdevice+0x178/0x2e9
 [<0223a872>] unregister_netdev+0xf/0x15
 [<129acad3>] bnep_session+0x697/0x6d2 [bnep]
 [<0211a8ee>] default_wake_function+0x0/0xc
 [<129ac43c>] bnep_session+0x0/0x6d2 [bnep]
 [<021041d9>] kernel_thread_helper+0x5/0xb

Comment 1 David Woodhouse 2004-09-06 10:02:43 UTC
bad: scheduling while atomic!
 [<022f3d9d>] schedule+0x2d/0x5a0
 [<0210659e>] dump_stack+0x11/0x13
 [<0211b765>] __might_sleep+0x82/0x8c
 [<021a5ef5>] sysfs_hash_and_remove+0x27/0x1ce
 [<129a4f32>] br_sysfs_removeif+0x18/0x20 [bridge]
 [<129a1908>] br_del_if+0x23/0x10b [bridge]
 [<129a2b27>] br_device_event+0x11f/0x17c [bridge]
 [<0212ccf5>] notifier_call_chain+0x17/0x30
 [<022a0550>] unregister_netdevice+0x178/0x2e9
 [<0223a872>] unregister_netdev+0xf/0x15
 [<129acad3>] bnep_session+0x697/0x6d2 [bnep]
 [<0211a8ee>] default_wake_function+0x0/0xc
 [<129ac43c>] bnep_session+0x0/0x6d2 [bnep]
 [<021041d9>] kernel_thread_helper+0x5/0xb
device bnep0 left promiscuous mode
net/bridge/br_if.c:105: spin_lock(net/bridge/br_if.c:0f020280) already
locked by net/bridge/br_notify.c/44
pan0: port 1(bnep0) entering disabled state
net/bridge/br_notify.c:82: spin_unlock(net/bridge/br_if.c:0f020280)
not locked
divert: freeing divert_blk for bnep0


Comment 2 David Woodhouse 2004-09-07 09:22:33 UTC
Fix at http://oss.sgi.com/projects/netdev/archive/2004-09/msg00144.html


Comment 3 Arjan van de Ven 2004-09-29 14:54:47 UTC
still relevant?

Comment 4 Dave Jones 2004-11-27 21:54:18 UTC
repeatable in b2 ? (or later?)

Comment 5 Dave Jones 2004-11-27 21:55:38 UTC
eyeballing the code shows that patch got integrated in b2. moving to modified


Comment 6 Jay Turner 2005-01-14 10:02:57 UTC
Closing this out since the patch has been in for some time and no negative
feedback.  Please reopen if there's still an issue with the latest code.


Note You need to log in before you can comment on or make changes to this bug.