Bug 1315735 - Tier: Possible crash/undefined behaviour if thread creation fails
Tier: Possible crash/undefined behaviour if thread creation fails
Status: CLOSED DUPLICATE of bug 1332219
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
All Unspecified
high Severity high
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 08:46 EST by Mohammed Rafi KC
Modified: 2016-05-03 03:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-03 03:01:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2016-03-08 08:46:32 EST
Description of problem:

In tier_start, we  spawn two threads one for promotion and one for demotion. If the thread creation fails we do a join with out having a value for thread variabl. This can lead into a crash or undefined behaviour.

Version-Release number of selected component (if applicable):

mainline

How reproducible:

Mosty

Steps to Reproduce:

1.create a tier volume
2.Attach tier process into gdb
3.using a break point try creating failure for thread creation in tier_start

Actual results:

crash
Expected results:

Should behave normally

Additional info:
Comment 1 Prasanna Kumar Kalever 2016-05-03 03:01:38 EDT

*** This bug has been marked as a duplicate of bug 1332219 ***

Note You need to log in before you can comment on or make changes to this bug.