Bug 131574 - Unclean shutdown can leave resources allocated
Summary: Unclean shutdown can leave resources allocated
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: clumanager (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 131576
TreeView+ depends on / blocked
 
Reported: 2004-09-02 13:38 UTC by Lon Hohberger
Modified: 2009-04-16 20:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 18:06:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix as described. (1.78 KB, patch)
2004-09-02 13:40 UTC, Lon Hohberger
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:491 high SHIPPED_LIVE Updated clumanager and redhat-config-cluster packages 2004-12-20 05:00:00 UTC

Description Lon Hohberger 2004-09-02 13:38:22 UTC
Description of problem:

If the cluster quorum dissolves, all remaining nodes halt services (as
expected).  If one or more services fails to stop cleanly, resources
could still be allocated on the owners of those services.

When a new quorum forms, it's conceivable that the initialization
(e.g. stop-before-start) would also fail, since the previous stop
attempt failed.

If a service has an ordered failover domain configured and, when the
new quorum forms, a higher-priority node than the previous owner is a
part of the new quorum, the service will be started on the new, higher
priority node.

At this point, there is a potential for resources to be allocated on
multiple members.


Version-Release number of selected component (if applicable):
1.2.3, 1.2.9, 1.2.12, 1.2.16


How reproducible:
Theoretical problem.


Solution: 
Reboot the node immediately if it can not free clustered resources
after a loss of quorum.

Comment 1 Lon Hohberger 2004-09-02 13:40:43 UTC
Created attachment 103390 [details]
Fix as described.

Comment 2 Lon Hohberger 2004-09-02 16:00:28 UTC
1.2.18pre1 patch (unsupported; test only, etc.)

http://people.redhat.com/lhh/clumanager-1.2.16-1.2.18pre1.patch

This includes the fix for this bug and a few others.

Comment 5 John Flanagan 2004-12-21 03:40:15 UTC
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-491.html



Note You need to log in before you can comment on or make changes to this bug.