Bug 1315742 - tempest CLI command does not find the entry points for subcommands
tempest CLI command does not find the entry points for subcommands
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tempest-lib (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity medium
: ga
: 8.0 (Liberty)
Assigned To: RHOS Maint
Luigi Toscano
:
Depends On:
Blocks: 1315667
  Show dependency treegraph
 
Reported: 2016-03-08 08:59 EST by Luigi Toscano
Modified: 2016-04-07 17:34 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-tempest-lib-0.13.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1315667
Environment:
Last Closed: 2016-04-07 17:34:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luigi Toscano 2016-03-08 08:59:08 EST
+++ This bug was initially created as a clone of Bug #1315667 +++

Description of problem:

$ tempest --help --debug
usage: tempest [--version] [-v] [--log-file LOG_FILE] [-q] [-h] [--debug]

Tempest cli application

optional arguments:
  --version            show program's version number and exit
  -v, --verbose        Increase verbosity of output. Can be repeated.
  --log-file LOG_FILE  Specify a file to log output. Disabled by default.
  -q, --quiet          Suppress output except warnings and errors.
  -h, --help           Show help message and exit.
  --debug              Show tracebacks on errors.

Commands:
Could not load EntryPoint.parse('account-generator = tempest.cmd.account_generator:TempestAccountGenerator')
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/help.py", line 22, in __call__
    factory = ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2259, in load
    if require: self.require(env, installer)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2272, in require
    working_set.resolve(self.dist.requires(self.extras),env,installer)))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
VersionConflict: (fixtures 0.3.14 (/usr/lib/python2.7/site-packages), Requirement.parse('fixtures>=1.3.1'))
Could not load EntryPoint.parse('cleanup = tempest.cmd.cleanup:TempestCleanup')
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/help.py", line 22, in __call__
    factory = ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2259, in load
    if require: self.require(env, installer)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2272, in require
    working_set.resolve(self.dist.requires(self.extras),env,installer)))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
VersionConflict: (fixtures 0.3.14 (/usr/lib/python2.7/site-packages), Requirement.parse('fixtures>=1.3.1'))
  complete       print bash completion command
  help           print detailed help for another command
Could not load EntryPoint.parse('init = tempest.cmd.init:TempestInit')
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/help.py", line 22, in __call__
    factory = ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2259, in load
    if require: self.require(env, installer)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2272, in require
    working_set.resolve(self.dist.requires(self.extras),env,installer)))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
VersionConflict: (fixtures 0.3.14 (/usr/lib/python2.7/site-packages), Requirement.parse('fixtures>=1.3.1'))
Could not load EntryPoint.parse('list-plugins = tempest.cmd.list_plugins:TempestListPlugins')
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/help.py", line 22, in __call__
    factory = ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2259, in load
    if require: self.require(env, installer)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2272, in require
    working_set.resolve(self.dist.requires(self.extras),env,installer)))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
VersionConflict: (fixtures 0.3.14 (/usr/lib/python2.7/site-packages), Requirement.parse('fixtures>=1.3.1'))
Could not load EntryPoint.parse('run-stress = tempest.cmd.run_stress:TempestRunStress')
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/help.py", line 22, in __call__
    factory = ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2259, in load
    if require: self.require(env, installer)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2272, in require
    working_set.resolve(self.dist.requires(self.extras),env,installer)))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
VersionConflict: (fixtures 0.3.14 (/usr/lib/python2.7/site-packages), Requirement.parse('fixtures>=1.3.1'))
Could not load EntryPoint.parse('verify-config = tempest.cmd.verify_tempest_config:TempestVerifyConfig')
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/help.py", line 22, in __call__
    factory = ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2259, in load
    if require: self.require(env, installer)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2272, in require
    working_set.resolve(self.dist.requires(self.extras),env,installer)))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 630, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
VersionConflict: (fixtures 0.3.14 (/usr/lib/python2.7/site-packages), Requirement.parse('fixtures>=1.3.1'))

Quick diagnosis:
Tempest is a branchless and its master branch inherited post-liberty dependencies through updates of global-requirements. The requirements are not provided by the packages, but tempest CLI seems to work anyway even with Liberty dependencies.
Lowering the dependencies in openstack-tempest and python-tempest-lib to the releases available in the packages seems to fix it.  

Version-Release number of selected component (if applicable):
openstack-tempest-liberty-20160126.1.el7ost.noarch
python-tempest-lib-0.13.0-1.el7ost.noarch

Cloned for python-tempest-lib, as the dependencies need to be fixed on both packages.
Comment 3 Luigi Toscano 2016-04-04 04:17:12 EDT
tempest CLI command is now operational:

$ tempest --help --debug
usage: tempest [--version] [-v] [--log-file LOG_FILE] [-q] [-h] [--debug]

Tempest cli application

optional arguments:
  --version            show program's version number and exit
  -v, --verbose        Increase verbosity of output. Can be repeated.
  --log-file LOG_FILE  Specify a file to log output. Disabled by default.
  -q, --quiet          Suppress output except warnings and errors.
  -h, --help           Show help message and exit.
  --debug              Show tracebacks on errors.

Commands:
  account-generator  Create accounts.yaml file for concurrent test runs.
  cleanup        Cleanup after tempest run
  complete       print bash completion command
  help           print detailed help for another command
  init           Setup a local working environment for running tempest
  list-plugins   List all tempest plugins
/usr/lib/python2.7/site-packages/tempest/stress/__init__.py:21: DeprecationWarning: Stress tests are deprecated and will be removed from Tempest in the Newton release.
  DeprecationWarning)
  run-stress     Run tempest stress tests
  verify-config  Verify your current tempest configuration

(it requires that -tests packages of available Tempest Plugins are installed, see also rhbz#1310767).

Verified on
openstack-tempest-liberty-20160317.1.el7ost.noarch
python-tempest-lib-0.13.0-3.el7ost.noarch
Comment 4 errata-xmlrpc 2016-04-07 17:34:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.