Bug 131583 - logrotate can not send any mails
Summary: logrotate can not send any mails
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: logrotate (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-09-02 15:35 UTC by Ruediger Oertel
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 3.7.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 21:57:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ruediger Oertel 2004-09-02 15:35:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
logrotate was changed to use execvp/execlp instead of system
to compress/mail log files.

this is used to do this:         execvp(mailArgv[0], mailArgv);
with: char * mailArgv[] = { mailCommand, "-s", subject, address, NULL };

and char * mailCommand = DEFAULT_MAIL_COMMAND;

now DEFAULT_MAIL_COMMAND is defined in config.h and reads:
    #define DEFAULT_MAIL_COMMAND "/bin/mail -s"

with the result: execvp: no such file or directory
true, since there is no binary called "/bin/mail -s" ...


Version-Release number of selected component (if applicable):
logrotate-3.7

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:

Comment 1 Miloslav Trmač 2004-10-19 21:57:49 UTC
Fixed in logrotate-3.7.1-2. Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.