Bug 1315877 - Ostree Repos should always be protected
Ostree Repos should always be protected
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Partha Aji
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1321771
  Show dependency treegraph
 
Reported: 2016-03-08 15:51 EST by Partha Aji
Modified: 2016-07-27 05:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:05:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
user won't have option to change protected ostree repo to unprotected mode from repo details page (66.59 KB, image/png)
2016-03-28 07:11 EDT, Sachin Ghai
no flags Details
UI doesn't show option to create ostree repo in unprotected mode (no option to select 'publish via http') (51.14 KB, image/png)
2016-03-28 07:13 EDT, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14089 None None None 2016-04-22 12:21 EDT

  None (edit)
Description Partha Aji 2016-03-08 15:51:38 EST
Pulp doesnot provide the facility to mark ostree repos as unprotected. We need make sure they are always protected
1) Need UI to hide Publish Via Http for ostree
2) Need Repo Details to hide the same
3) Need model to complain if that field gets changed to unprotected.
Comment 1 Partha Aji 2016-03-08 15:51:40 EST
Created from redmine issue http://projects.theforeman.org/issues/14089
Comment 2 Partha Aji 2016-03-08 15:51:43 EST
Upstream bug assigned to paji@redhat.com
Comment 4 Bryan Kearney 2016-03-15 16:04:58 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14089 has been closed
-------------
Partha Aji
Applied in changeset commit:katello|82232a3acd9c954c4c3285b626aa81899e0fd7e8.
Comment 5 Sachin Ghai 2016-03-28 07:05:02 EDT
Verified with sat6.2 beta snap5.1

On creating a ostree repo by enabling unprotected mode, hammer raises error:

 ~]# hammer -u admin -p changeme repository create --name f22_ostree --organization-id 1 --product ostree --url https://dl.fedoraproject.org/pub/fedora/linux/atomic/22/ --publish-via-http yes --content-type ostree
Could not create the repository:
  Validation failed: OSTree Repositories cannot be unprotected.
[root@cloud-qe-3 ~]# 


Similar error while updating it:

~]# hammer -u admin -p changeme repository update --id 29 --organization-id 1 --publish-via-http yes
Could not update the repository:
  Validation failed: OSTree Repositories cannot be unprotected.
Comment 6 Sachin Ghai 2016-03-28 07:11 EDT
Created attachment 1140821 [details]
user won't have option to change protected ostree repo to unprotected mode from repo details page
Comment 7 Sachin Ghai 2016-03-28 07:13 EDT
Created attachment 1140822 [details]
UI doesn't show option to create ostree repo in unprotected mode (no option to select 'publish via http')
Comment 8 Sachin Ghai 2016-03-28 07:13:53 EDT
Moving this bz to verified as per comment 5 6 and 7.
Comment 11 errata-xmlrpc 2016-07-27 05:05:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.