This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1315894 - katello-remove does not remove many things
katello-remove does not remove many things
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.1.7
x86_64 Linux
low Severity low (vote)
: GA
: 6.2
Assigned To: Chris Roberts
Bruno Rocha
http://projects.theforeman.org/issues...
: Triaged
: 1320234 1339371 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker/GSS_Sat6_Tracker
  Show dependency treegraph
 
Reported: 2016-03-08 17:18 EST by Chris Roberts
Modified: 2016-07-27 07:26 EDT (History)
8 users (show)

See Also:
Fixed In Version: katello-3.0.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1342496 (view as bug list)
Environment:
Last Closed: 2016-07-27 07:26:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14125 None None None 2016-04-22 12:12 EDT

  None (edit)
Description Chris Roberts 2016-03-08 17:18:44 EST
Description of problem:
katello-remove should remove /etc/gutterball directory

How reproducible:


Steps to Reproduce:
1. install sat 6.1
2. katello-remove
3. dir is still present

Actual results:
rw-r--r--. 1 root   root    974 Mar  8 16:12 gutterball.conf.rpmsave

Expected results:
/etc/gutterball to be removed

Additional info:

marking as 6.2, tested with latest snap and still keeps directory
Comment 2 Bryan Kearney 2016-03-09 16:08:51 EST
Upstream bug component is Installer
Comment 3 Mike McCune 2016-04-13 13:02:26 EDT
From https://bugzilla.redhat.com/show_bug.cgi?id=1320234 more things to consider:

"""
Install 6.2 and remove katello after playing around. 

After katello-remove, try to re install satellite with regular instructions). Install fails with below error as its not able to clean old ssl certificates. 

---
Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 Proxy pman05.perf.lab.eng.bos.redhat.com cannot be registered (422 Unprocessable Entity): Unable to communicate with the proxy: ERF12-2530 [ProxyAPI::ProxyException]: Unable to detect features ([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verif...) for proxy https://pman05.perf.lab.eng.bos.redhat.com:8443/features Please check the proxy is configured and running on the host.
 /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[pman05.perf.lab.eng.bos.redhat.com]/ensure: change from absent to present failed: Proxy pman05.perf.lab.eng.bos.redhat.com cannot be registered (422 Unprocessable Entity): Unable to communicate with the proxy: ERF12-2530 [ProxyAPI::ProxyException]: Unable to detect features ([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verif...) for proxy https://pman05.perf.lab.eng.bos.redhat.com:8443/features Please check the proxy is configured and running on the host.
 /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[pman05.perf.lab.eng.bos.redhat.com]: Failed to call refresh: Proxy pman05.perf.lab.eng.bos.redhat.com cannot be registered 
---


Had to remove /etc/foreman-installer manually to start fresh install

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install 6.2 and remove using katello-remove
2. Try to reinstall again
"""
Comment 4 Mike McCune 2016-04-13 13:02:58 EDT
*** Bug 1320234 has been marked as a duplicate of this bug. ***
Comment 5 Pradeep Kumar Surisetty 2016-04-15 03:39:31 EDT
similar one with capsule-remove also

https://bugzilla.redhat.com/show_bug.cgi?id=1327442
Comment 6 Bryan Kearney 2016-05-17 10:19:43 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14125 has been closed
Comment 7 Stephen Benjamin 2016-05-24 16:26:56 EDT
*** Bug 1339371 has been marked as a duplicate of this bug. ***
Comment 8 Bruno Rocha 2016-06-29 17:59:25 EDT
The original bug is fixed
The /etc/gutterball is being removed.

re-installation worked without errors


Full log privatelly attached


Tested after re-install:

[root@ibm-x3550m3-06 ~]# hammer -u admin -p changeme ping
candlepin:      
    Status:          ok
    Server Response: Duration: 48ms
candlepin_auth: 
    Status:          ok
    Server Response: Duration: 45ms
pulp:           
    Status:          ok
    Server Response: Duration: 50ms
foreman_tasks:  
    Status:          ok
    Server Response: Duration: 915ms
Comment 10 Bryan Kearney 2016-07-27 07:26:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.