Bug 1315897 - Hypervisor checkin failed with not-null property error
Hypervisor checkin failed with not-null property error
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin (Show other bugs)
6.1.7
x86_64 Linux
medium Severity medium (vote)
: GA
: --
Assigned To: satellite6-bugs
Katello QA List
: Reopened
Depends On: 1311664
Blocks: 1320316
  Show dependency treegraph
 
Reported: 2016-03-08 17:43 EST by Chris Roberts
Modified: 2016-07-27 07:02 EDT (History)
7 users (show)

See Also:
Fixed In Version: candlepin-0.9.54-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1320316 (view as bug list)
Environment:
Last Closed: 2016-07-27 07:02:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Roberts 2016-03-08 17:43:06 EST
Description of problem:
Seeing 2 cases now where hypervisor checkins fail and looking in candlepin logs 

Might be a dup of this bz but not sure

1311664

we see the following

ERROR org.candlepin.resource.HypervisorResource - Hypervisor checkin failed
org.hibernate.PropertyValueException: not-null property references a null or transient value: org.candlepin.model.GuestId.guestId


Version-Release number of selected component (if applicable):

candlepin-0.9.49.11-1.el7.noarch                            Wed Mar  2 12:09:31 
candlepin-common-1.0.22-1.el7.noarch                        Fri Oct  2 20:32:27 
candlepin-guice-3.0-2_redhat_1.el7.noarch                   Fri Oct  2 20:27:54 
candlepin-scl-1-5.el7.noarch                                Fri Oct  2 20:32:17 
candlepin-scl-quartz-2.1.5-6.el7.noarch                     Fri Oct  2 20:32:17 ff14cfafd37110	RSA/SHA256, Thu Sep  4 07:49:48 2014, Key ID 199e2f91fd431d51
candlepin-scl-rhino-1.7R3-3.el7.noarch                      Fri Oct  2 20:32:15 
candlepin-scl-runtime-1-5.el7.noarch                        Fri Oct  2 20:27:55 
candlepin-selinux-0.9.49.11-1.el7.noarch                    Wed Mar  2 12:09:34 
candlepin-tomcat-0.9.49.11-1.el7.noarch


Actual results:

http://pastebin.test.redhat.com/355029

Expected results:
Hypervisors to check in

Additional info:

Traceback from virt-who server

2016-02-23 09:23:52,731 [ERROR]  @subscriptionmanager.py:171 - Communication with server failed:
Traceback (most recent call last):
  File "/usr/share/virt-who/manager/subscriptionmanager/subscriptionmanager.py", line 167, in hypervisorCheckIn
    result = self.connection.hypervisorCheckIn(config.owner, config.env, serialized_mapping)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 903, in hypervisorCheckIn
    res = self.conn.request_post(url, host_guest_mapping)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 647, in request_post
    return self._request("POST", method, params)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 564, in _request
    self.validateResponse(result, request_type, handler)
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 611, in validateResponse
    raise RestlibException(response['status'], error_msg, response.get('headers'))
RestlibException: Runtime Error org.hibernate.PropertyValueException: not-null property references a null or transient value: org.candlepin.model.GuestId.guestId at org.hibernate.engine.internal.Nullability.checkNullability:103
2016-02-23 09:23:52,732 [ERROR]  @virtwho.py:177 - Unable to send data: Communication with subscription manager failed with code 500: Runtime Error org.hibernate.PropertyValueException: not-null property references a null or transient value: org.candlepin.model.GuestId.guestId at org.hibernate.engine.internal.Nullability.checkNullability:103
2016-02-23 09:23:52,733 [ERROR]  @virtwho.py:305 - Sending data failed 5 times, report skipped
Comment 2 Kedar Bidarkar 2016-03-15 11:43:51 EDT
what exactly we mean by "hypervisor checking failed", does it mean when 'RHEVM/RHEV's being registered to satellite6' as hypervisor with virt-who configured ?

Can you please provide more detailed steps to reproduce this bug?
Comment 3 Barnaby Court 2016-03-15 17:05:24 EDT
This has been backported to the 0.9.54 hotfix branch
Comment 4 Chris Roberts 2016-04-01 10:34:46 EDT
Kedar,

*** This bug has been marked as a duplicate of bug 1311664 ***
Comment 5 Mike McCune 2016-04-05 10:54:11 EDT
we still need a Satellite 6 product bug if we are to ship this in a Satellite release.
Comment 6 Chris Roberts 2016-04-12 10:40:30 EDT
Kedar,

I was seeing mostly on VMWARE. On the virt-who machine you would see an Internal server error and on the satellite you would see the following:

ERROR org.candlepin.resource.HypervisorResource - Hypervisor checkin failed
org.hibernate.PropertyValueException: not-null property references a null or transient value: org.candlepin.model.GuestId.guestId
Comment 7 Bryan Kearney 2016-07-27 07:02:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.