Bug 13159 - More LDAP auth bugs
More LDAP auth bugs
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: authconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-28 08:50 EDT by lars
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-03 03:59:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lars 2000-06-28 08:50:44 EDT
I tried running authconfig manually after the installer had completed in
order to enable LDAP authentication.  No luck -- in fact, I noticed that
the ldap.conf in /etc (which is used by the pam_ldap and nss_ldap modules)
contained no 'host' or 'base' directives at all.
Comment 1 Nalin Dahyabhai 2000-06-28 09:10:20 EDT
That's odd.  Commenting them out on my test machine and entering new values in
the dialog causes new host and base directives to be appended.  Do you have an
existing configuration file that for some reason you wouldn't be able to read?
Or are you somehow managing to run it as a non-root user?
Comment 2 lars 2000-06-28 09:17:31 EDT
This is probably an artifact of bug 13157, which probably ate the entries during
the install.  However, it does point to a bug in authconfig as well, which ought
to deal sanely when there are no existing (commented or otherwise) host or base
entries in the config file.
Comment 3 lars 2000-06-28 09:20:49 EDT
Adding bogus entries:

  host foo
  base foo

And re-running authconfig makes things work as expected.
Comment 4 Nalin Dahyabhai 2000-07-03 03:59:41 EDT
I still can't reproduce this problem.  Removing my ldap.conf file and running
authconfig (in both interactive and kickstart modes) generates a correct file.

Note You need to log in before you can comment on or make changes to this bug.