Bug 1315917 - [RFE] Support exposing secret keys in environment variables
[RFE] Support exposing secret keys in environment variables
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kubernetes (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Chaloupka
atomic-bugs@redhat.com
: Extras, FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 20:21 EST by Kenjiro Nakayama
Modified: 2016-05-12 10:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: kubernetes-1.2.0-0.10.git738b760.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 10:52:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenjiro Nakayama 2016-03-08 20:21:55 EST
1. Proposed title of this feature request

Support exposing secret keys in environment variables

2. Who is the customer behind the request?

(In private)

3. What is the nature and description of the request?

Exposing secret keys in environment variables has been supported after the release upstream kuberentes v1.2.0-alpha.7. The customer needs the feature in RH's kubernetes package.

4. Why does the customer need this? (List the business requirements here)

The feature will allow their Kubernetes cluster to be compliant with security, allowing secure management of containers including authorization and credentials of communications with their external systems.

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?

No. But it has already implemented in upstream.

Report: https://github.com/kubernetes/kubernetes/issues/4710
PR    : https://github.com/kubernetes/kubernetes/pull/18298

*NOTE* It contains kubernetes v1.2.0-alpha.7.

9. Is the sales team involved in this request and do they have any additional input?

No.

10. List any affected packages or components.

kubernetes
kubernetes-client
kubernetes-master
kubernetes-node
Comment 10 errata-xmlrpc 2016-05-12 10:52:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1032.html

Note You need to log in before you can comment on or make changes to this bug.