Bug 1315945 - Cannot select Azure Subnet if first VIrtual Private Cloud is selected.
Cannot select Azure Subnet if first VIrtual Private Cloud is selected.
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.6.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Patrik Holop
azure:network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 00:22 EST by Jeff Teehan
Modified: 2017-08-30 08:18 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:40:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Teehan 2016-03-09 00:22:34 EST
Description of problem:
I'm provisioning a VM from an image, when I get to the Environment page, if the first Virtual Private Cloud occurrence is the one I want, then you cannot select it's subnet.  To do so, you have to select the second or some other VPC and then select the first one again.  Only then can you select the Subnet.

Version-Release number of selected component (if applicable):
cfme-hyperv-5.6.0.0-nightly-20160308112121-1.x86_64.vhd

How reproducible:
Every time.

Steps to Reproduce:
1.  Provision an Azure Instance from an Image.
2.  At the environment page, with selecting a VPC, try to select the first entry's subnet.
3.  Select the second entry and then select the first and then it works.

Actual results:
Can't select the desired subnet on the first choice.

Expected results:
Select it.

Additional info:
Find me if you need a quick meeting to see it.
Comment 2 Harpreet Kataria 2016-03-10 10:39:32 EST
https://github.com/ManageIQ/manageiq/pull/7199
Comment 3 CFME Bot 2016-03-10 18:20:41 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/2bb0db8de0f795a9c65f6028b55ff3461e90062d

commit 2bb0db8de0f795a9c65f6028b55ff3461e90062d
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Mar 10 10:34:30 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Mar 10 10:34:30 2016 -0500

    Show <choose> in Virtual Private Cloud select by default.
    
    Removed default: nil from dialog, so VPC pull down displays <Choose> as default selected option to get other pull downs on the screen populated appropriately based upon Virtual Private Cloud pull down selection.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1315945
    Issue #6501

 product/dialogs/miq_dialogs/miq_provision_amazon_dialogs_template.yaml | 1 -
 product/dialogs/miq_dialogs/miq_provision_azure_dialogs_template.yaml  | 1 -
 2 files changed, 2 deletions(-)
Comment 4 Jeff Teehan 2016-03-31 00:54:39 EDT
This is a perfect solution.  Nice job.  Moving to Verified using Beta1 on https://10.16.6.85/miq_request
Comment 6 errata-xmlrpc 2016-06-29 11:40:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.