Bug 1315959 - Cannot move the master storage domain to maintenance
Cannot move the master storage domain to maintenance
Status: CLOSED DUPLICATE of bug 1315960
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.3.3
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.6
: ---
Assigned To: Ala Hino
Aharon Canan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 01:55 EST by Nelly Credi
Modified: 2016-03-09 04:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 04:23:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine log (9.22 MB, text/plain)
2016-03-09 01:55 EST, Nelly Credi
no flags Details

  None (edit)
Description Nelly Credi 2016-03-09 01:55:42 EST
Created attachment 1134396 [details]
engine log

Description of problem:
Sometimes the master domain cannot be moved to maintenance mode, with this error
Failed to deactivate storage domain nfs_0 (Data Center golden_env_mixed)

Version-Release number of selected component (if applicable):


How reproducible:
30%

Steps to Reproduce:
1.add master domain wait for everything to be up
2. try to put it into maintenance 
3.

Actual results:
Failed to deactivate storage domain nfs_0 (Data Center golden_env_mixed)

Expected results:
should be able to put it into maintenance

Additional info:
 looking at the logs I saw that there are tasks causing the failure:

SpmStopVDSCommand::Not stopping SPM on vds 'host_mixed_4', pool id '457833c9-adf9-4939-ae00-9dc198c50039' as there are uncleared tasks
.....
DeactivateStorageDomainCommand] (org.ovirt.thread.pool-6-thread-5) [253137b9] Aborting execution due to failure to stop SPM

 when I checked the tasks table I saw a lot of them (123) with:
 status | action_type 
--------+-------------
      2 |        1010
    
vdsm_task_id = 00000000-0000-0000-0000-000000000000 


I have kept an environment in this state and we see it happening in dev ci as well
Comment 1 Nelly Credi 2016-03-09 04:23:34 EST
Accidentally opened twice.

*** This bug has been marked as a duplicate of bug 1315960 ***

Note You need to log in before you can comment on or make changes to this bug.